Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236536 - Glibc changes cause UT2004 to crash
Summary: Glibc changes cause UT2004 to crash
Keywords:
Status: CLOSED DUPLICATE of bug 235864
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 08:55 UTC by Mephisto
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 13:00:24 UTC


Attachments (Terms of Use)

Description Mephisto 2007-04-16 08:55:31 UTC
Description of problem:
When trying to play UT2004, the program segfaults when loading a lot of maps.
This didn't happen a few months ago and i haven't changed anything to the game
since then, since i got hooked on some other game somewhere in February (maybe
even end January) and haven't played it since then. The problem goes away when i
downgrade glibc to the one from FC6. Older rawhide builds would probably be fine
too, but i cant test that since they're no longer available. Judging from the
changelog and its dates, -14 has worked for sure, and probably -15 too. Anything
after that could have introduced the crashes.

Version-Release number of selected component (if applicable):
glibc-2.5.90-20

How reproducible:
always, but not with all maps

Steps to Reproduce:
1. Start up ut2004. Ddon't know if it works with the demo, but i suspect it does.
2. Load a map that crashes, i know BR-Colossus and CTF-BridgeOfFate make it
crash, and the other demo maps don't.
3. Watch it segfault after the loading screen...
  
Actual results:
The game segfaults

Expected results:
The game should run

Additional info:
I can't get too much of a descriptive stack trace, as it's a closed source
program and doesn't have debug symbols, but maybe this is of any help:

[New Thread 37149584 (LWP 3935)]
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
[New Thread 116603792 (LWP 3936)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1488576 (LWP 3934)]
0x003ef8c7 in wmemset () from /lib/libc.so.6
(gdb) bt
#0  0x003ef8c7 in wmemset () from /lib/libc.so.6
#1  0x003bd93b in __printf_fp () from /lib/libc.so.6
#2  0x00000030 in ?? ()
#3  0x00000030 in ?? ()
#4  0x00000030 in ?? ()

Comment 1 Jakub Jelinek 2007-04-16 13:00:24 UTC

*** This bug has been marked as a duplicate of 235864 ***


Note You need to log in before you can comment on or make changes to this bug.