Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236534 - cannot run mock for same chroot by different users
Summary: cannot run mock for same chroot by different users
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 08:36 UTC by Jeroen Janssen
Modified: 2013-01-10 04:15 UTC (History)
1 user (show)

Fixed In Version: 0.7.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-21 20:04:27 UTC


Attachments (Terms of Use)

Description Jeroen Janssen 2007-04-16 08:36:23 UTC
Description of problem:

It's not possible for different users to run mock on the same chroot.
This is due to a permission problem on /var/lib/mock/<chroot>/state/status,
which only allows write acces to the owner of the file instead of the mock group.

Version-Release number of selected component (if applicable):

mock 0.6.11-1.fc6

How reproducible:

Allways

Steps to Reproduce:
1. have 2 users in the mock group
2. build a srpm in mock for chroot 'a' by 'userx'
3. build a srpm in moch for chroot 'a' by 'usery'
  
Actual results:

mock permission failure on /var/lib/mock/<chroot>/state/status
(permission rw-r--r--  userx mock)

Expected results:

/var/lib/mock/<chroot>/state/status to have write permission for group
(permission rw-rw-r--  userx mock)

Additional info:

Comment 1 Fedora Update System 2007-06-14 21:12:23 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 2 Fedora Update System 2007-06-21 20:03:58 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.