Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236528 - TKIP errors when using WPA
Summary: TKIP errors when using WPA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: John W. Linville
QA Contact: Martin Jenner
URL: http://tinyurl.com/35n8mf
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 03:51 UTC by Tom Sightler
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:46:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch against ieee80211-1.1.14 (deleted)
2007-04-16 03:51 UTC, Tom Sightler
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Tom Sightler 2007-04-16 03:51:19 UTC
Description of problem:
When attempting to use WPA with an Intel wireless card (ipw2200/ipw3945) on a 
Dell D820 laptop once the wireless connection is put under load the connection 
will eventually drop with errors similar to the following in the log:

TKIP: ICV error detected: STA=00:04:0e:7e:7a:58
N/A: Michael MIC verification failed for MSDU from 00:04:0e:7e:7a:58 keyidx=0
wlan: MSDU decryption/MIC verification failed (SA=00:04:0e:7e:7a:58 keyidx=0)

This is a known issue with the 1.1.13 version of the ieee80211 module 
components, especially when running on SMP systems (very common with 
hyperthreading and dual-core desktops everywhere).  A patch has been available 
for months, and versions of the ieee80211 stack >= 1.2.15 do not have this 
issues.

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.1.el5
ieee80211 versions 1.1.13

How reproducible:
Always

Steps to Reproduce:
1. Configure any wireless card which uses the ieee80211 stack
2. Connect to a WPA enabled AP (WEP can cause the problem as well)
3. Pass a lot of traffic (usually hundreds of megabytes)
4. Watch the logs for errors such as "TKIP: ICV error detected" or "N/A: Michael 
MIC verification failed for MSDU"
5. Connection will eventually drop and probably not recover easily.
  
Actual results:
Errors are logged and connection eventually drops

Expected results:
Wireless connection should be stable

Additional info:
I'll attache the patch that was posted on one of the ipw-devel lists for this 
issue but it would probably be better to actually upgrade to a newer version of 
the ieee80211 stack.

Comment 1 Tom Sightler 2007-04-16 03:51:19 UTC
Created attachment 152663 [details]
Patch against ieee80211-1.1.14

Comment 2 Ernie Petrides 2007-09-11 22:01:48 UTC
The changes above have been committed to the RHEL5.1 kernel, which is now in beta.

Don, I found the changes in the following patch tracking file:

  softmac-updates-from-2-6-21-1.patch.1

Comment 3 Tom Sightler 2007-09-11 22:38:27 UTC
I have been running the RHEL5.1 beta kernel for several weeks on this same 
laptop and the problem seems to be corrected.  Thanks for the attention to this 
issue.

Tom


Comment 6 errata-xmlrpc 2007-11-07 19:46:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.