Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236523 - Guest Installer Error virDomainCreateLinux failed vif
Summary: Guest Installer Error virDomainCreateLinux failed vif
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 01:12 UTC by Jens Petersen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-05 02:40:10 UTC


Attachments (Terms of Use)
virt-manager.log (deleted)
2007-04-16 03:58 UTC, Jens Petersen
no flags Details | Diff
audit.log.gz (deleted)
2007-04-24 09:52 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2007-04-16 01:12:26 UTC
Description of problem:
When I try to install guest OS's on my rawhide x86_64 box, I get a error
message.

Version-Release number of selected component (if applicable):
0.3.2-2.fc7

How reproducible:
every time

Steps to Reproduce:
1. try to install rawhide or rhel5
  
Actual results:
Guest Installer Error

ERROR: virDomainCreateLinux() failed POST ...: (xend.err 'Device 0 (vif) could
not be connected. Hotplug scripts not working.')

("..." text is translated.)

Expected results:
No error and installation to complete.

Comment 1 Jens Petersen 2007-04-16 01:36:27 UTC
Sorry not quite sure what the right component for this should be.
Maybe it should be libvirt or python-virtinst?

Comment 2 Jens Petersen 2007-04-16 03:58:45 UTC
Created attachment 152664 [details]
virt-manager.log

Here is "/root/.virt-manager/virt-manager.log".

Comment 3 Daniel Berrange 2007-04-17 13:43:12 UTC
Can you attach the output of 'ifconfig -a' and 'brctl show'

Can you also indicate whether SELinux is enabled, and if so, are there any AVC
warnings in /var/log/audit/audit.log or /var/log/messages ?

Comment 4 Jens Petersen 2007-04-17 22:14:41 UTC
(In reply to comment #3)
> Can you attach the output of 'ifconfig -a' and 'brctl show'
> Can you also indicate whether SELinux is enabled, and if so, are there any AVC
> warnings in /var/log/audit/audit.log or /var/log/messages ?

Yes it is a default installation and selinux is enabled.
I am away until next week - so let me follow up with the information
you requested then.

Comment 5 Jens Petersen 2007-04-24 09:42:48 UTC
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1A:A0:09:D3:A3  
          inet addr:172.16.45.65  Bcast:172.16.45.255  Mask:255.255.254.0
          inet6 addr: fe80::21a:a0ff:fe09:d3a3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:27715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3226 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9970678 (9.5 MiB)  TX bytes:222397 (217.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11268 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:97727864 (93.2 MiB)  TX bytes:97727864 (93.2 MiB)

peth0     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:27717 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3224 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10081666 (9.6 MiB)  TX bytes:237117 (231.5 KiB)
          Interrupt:17 

veth1     Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

veth2     Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

veth3     Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:3226 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27715 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:222397 (217.1 KiB)  TX bytes:9970678 (9.5 MiB)

vif0.1    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vif0.2    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vif0.3    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:9297 (9.0 KiB)

xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:21733 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1128533 (1.0 MiB)  TX bytes:0 (0.0 b)

# brctl show
bridge name	bridge id		STP enabled	interfaces
virbr0		8000.000000000000	no		
xenbr0		8000.feffffffffff	no		peth0
							vif0.0


Comment 6 Jens Petersen 2007-04-24 09:51:04 UTC
/var/log/messages has:

Apr 24 19:09:20 dhcp-65 setroubleshoot:      SELinux is preventing blktap
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:09:20 dhcp-65 setroubleshoot:      SELinux is preventing blktap
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:09:20 dhcp-65 setroubleshoot:      SELinux is preventing vif-bridge
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:11:00 dhcp-65 last message repeated 2 times
Apr 24 19:11:00 dhcp-65 setroubleshoot:      SELinux is preventing vif-bridge
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:11:00 dhcp-65 setroubleshoot:      SELinux is preventing blktap
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:11:00 dhcp-65 setroubleshoot:      SELinux is preventing blktap
(udev_t) "search" to xen (xend_var_log_t).      For complete SELinux messages.
run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60
Apr 24 19:11:00 dhcp-65 setroubleshoot:      SELinux is preventing
xen-hotplug-cle (udev_t) "search" to xen (xend_var_log_t).      For complete
SELinux messages. run sealert -l 64954467-dee0-4a49-8834-3a5e0a8f0c60



Comment 7 Jens Petersen 2007-04-24 09:52:50 UTC
Created attachment 153340 [details]
audit.log.gz

Comment 8 Jens Petersen 2007-04-27 00:07:05 UTC
Just to add after setting selinux to permissive, I was able to install rawhide
as a guest OS (couldn't get X up but that is another story I guess).

Comment 9 Daniel Berrange 2007-04-27 00:09:54 UTC
I can confirm I see a whole bunch of problems when SELinux is enabled preventing
me from creating domains, so it looks like a general issue with Xen + SELinux.
I'll investigate just what has changed to sort out policy additions.


Comment 10 Red Hat Bugzilla 2007-07-25 02:08:03 UTC
change QA contact

Comment 11 Daniel Berrange 2007-10-05 02:40:10 UTC
AFAICK, we solved all the SELinux errors against FC7, so closing this bug.
Re-open if there are continuing problems on F8 rawhide.



Note You need to log in before you can comment on or make changes to this bug.