Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236518 - pup installs update which breaks dependencies
Summary: pup installs update which breaks dependencies
Keywords:
Status: CLOSED DUPLICATE of bug 236009
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-15 23:56 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 16:42:44 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2007-04-15 23:56:30 UTC
gnucash-2.0.5-3.fc7, which I installed on March 22, requires
libgtkhtml-3.8.so.15.    gtkhtml3-3.14.1-1.fc7, which pup installed on April 11,
contains a later version of that library.  Hence, after updating with pup,
gnucash no longer works.  pup should not have installed a package which broke a
dependency for an existing package.  Rpm gets this right, i.e., if you try to
use rpm to install an update for a package which removes a dependency of another
package, rpm will refuse to do it without --nodeps.

I'm marking this a high-priority defect because I don't think it's at all
acceptable for pup to be able to break installed applications.

Comment 1 Jeremy Katz 2007-04-25 16:42:44 UTC

*** This bug has been marked as a duplicate of 236009 ***


Note You need to log in before you can comment on or make changes to this bug.