Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236500 - Changing brightness crashes X server
Summary: Changing brightness crashes X server
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-15 13:43 UTC by Jonathan Underwood
Modified: 2018-04-11 11:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-28 16:59:22 UTC


Attachments (Terms of Use)
X server log following X server crashing (deleted)
2007-04-15 13:45 UTC, Jonathan Underwood
no flags Details
xorg.conf (deleted)
2007-04-15 13:46 UTC, Jonathan Underwood
no flags Details
Xorg log (deleted)
2007-04-15 13:51 UTC, Jonathan Underwood
no flags Details
Output of lspci -vvv (deleted)
2007-04-15 13:54 UTC, Jonathan Underwood
no flags Details

Description Jonathan Underwood 2007-04-15 13:43:41 UTC
Description of problem:
On a Dell XPS M1210 if I try to adjust the screen brightness (Fn+up/down arrow)
the Xserver crashes.

Pressing the same keys in one of the tty screens gives
atkbd.c: Unknown key pressed (translated set 2, code 0x85 on isa0060/serio0)
atkbd.c: Use 'setkeycodes e005 <keycode>' to make it known

Nonetheless, the brightness *is* successfully adjusted.

So, I'm unsure if this is a kernel bug or an Xserver bug. But, the Xserver
shouldn't just die, I'm sure.

This is on a fully updated FC-6 box as of today.

Linux renton.jgu 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:46:00 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

Version-Release number of selected component (if applicable):
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-fonts-75dpi-7.1-2
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-xinit-1.0.2-15.fc6
xorg-x11-drv-mouse-1.2.1-1.fc6
xorg-x11-drv-mga-1.4.5-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-utils-7.1-2.fc6
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-drv-s3-0.5.0-1.fc6
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-font-utils-7.1-2
xorg-x11-xfs-1.0.2-3.1
xorg-x11-drv-vesa-1.2.1-4
xorg-x11-fonts-Type1-7.1-2
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-i810-1.6.5-10.fc6
xorg-x11-drv-tdfx-1.3.0-2.fc6
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-twm-1.0.1-3.1
xorg-x11-apps-7.1-3.fc6
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-fonts-truetype-7.1-2
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-trident-1.2.3-1.fc6
xorg-x11-drv-sis-0.9.1-7
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drivers-7.1-3
xorg-x11-server-Xorg-1.1.1-47.8.fc6
xorg-x11-fonts-base-7.1-2
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2
xorg-x11-drv-via-0.2.1-7
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-ati-6.6.3-1.fc6


How reproducible:
Everytime

Steps to Reproduce:
1.Press the buttons to increase or decrease brightness in X session
2.
3.
  
Actual results:
X server crashes and brightness changes

Expected results:
Brightness changes without killing X

Additional info:
Will attach configuration and log files ...

Comment 1 Jonathan Underwood 2007-04-15 13:45:18 UTC
Created attachment 152642 [details]
X server log following X server crashing

This is with my xorg.conf configuration (to follow)

Comment 2 Jonathan Underwood 2007-04-15 13:46:18 UTC
Created attachment 152643 [details]
xorg.conf

Comment 3 Jonathan Underwood 2007-04-15 13:51:00 UTC
Created attachment 152644 [details]
Xorg log

This is a log file after crashing the X server by changing the brightness. This
was with no /etc/X11/xorg.conf file present.

Comment 4 Jonathan Underwood 2007-04-15 13:54:12 UTC
Created attachment 152645 [details]
Output of lspci -vvv

Comment 5 Jonathan Underwood 2007-04-15 14:03:38 UTC
Inspired by this page:

http://www.thinkwiki.org/wiki/Problem_with_LCD_brightness_buttons

I issued a modprobe -r video as root. Now in X, pressing the brightness increase
and decrease key combinations doesn't change the brightness at all, but also X
doesn't crash. I don't know if one would call that progress or not :). Certainly
seems to be something to do with the video kernel module and X.

Comment 6 Jonathan Underwood 2007-04-15 14:05:19 UTC
Also perhaps related:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/95937

Comment 7 Matěj Cepl 2007-04-16 08:34:41 UTC
Isn't this DUP of bug 220466?

Comment 8 Jonathan Underwood 2007-04-16 09:18:03 UTC
(In reply to comment #7)
> Isn't this DUP of bug 220466?

Difficult to say. Certainly similar hardware, but 220466 doesn't report the
Xserver crashing and restarting, but rather the screen going black. I looked
thru' the Xorg.log posted there, but it didn't seem to contain any kind of
backtrace, so impossible to say if it's the same. It's probably related, for
sure, but I'm not sure it's a DUP.

Comment 9 Adam Jackson 2007-04-24 15:10:24 UTC
Yeah, not a dupe, this is an actual crash.

Comment 10 Adam Jackson 2007-07-31 18:07:12 UTC
intel driver should fix this in F7 and later.  It goes out of its way to
suppress BIOS adjustment of the display brightness and handle it internally instead.

Comment 11 Adam Jackson 2007-08-28 16:59:22 UTC
No intel driver update is planned for FC6, so I'm calling this fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.