Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236488 - Review Request: aimject - AIM packet injection tool
Summary: Review Request: aimject - AIM packet injection tool
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Mahowald
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2007-04-15 05:49 UTC by Joe Rozner
Modified: 2009-07-17 19:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-31 14:53:28 UTC


Attachments (Terms of Use)

Description Joe Rozner 2007-04-15 05:49:31 UTC
I'm still looking for a sponsor so that I may become a contributor though this isn't my first package.
Spec URL: http://deadbytes.net/packages/fedora/specs/aimject/aimject.spec
SRPM URL: <http://deadbytes.net/packages/fedora/srpms/aimject-1.0-1.src.rpm
Description:
Aimject facilitates man-in-the-middle attacks against AOL Instant Messenger's
OSCAR protocol via a simple GTK interface.

FEATURES

  * sign-on/off detection
  * message interception/decoding
  * message injection into arbitrary conversations
    * synchronization of AIM sequence numbers and fnac ids
    * cloning of font styles/screenname formatting to avoid detection
  * selective muting of conversation participants
  * session statistics
  * integrated ARP/DNS spoofing

Comment 1 Mamoru TASAKA 2007-05-25 18:20:21 UTC
It seems that you are now sponsored (bug 232855)?

Comment 2 Mamoru TASAKA 2007-06-09 17:30:58 UTC
Removing needsponsor

Comment 3 John Mahowald 2007-09-27 15:01:05 UTC
Builds fine.

However, you do need to specify GPL version now, as per
http://fedoraproject.org/wiki/Licensing   Looks like 2 and later, from a source
file.

Remove the Requires: gtk2  as rpm can figure that out.

Comment 4 Mamoru TASAKA 2007-12-19 14:30:19 UTC
What is the status of this bug?

Comment 5 Joe Rozner 2007-12-20 17:32:54 UTC
Oh, I thought this had been closed a long time ago. I'll see if I can get this
fixed up today after work and get it committed, otherwise I'll make sure I do it
tomorrow.

Comment 6 Joe Rozner 2007-12-23 00:42:30 UTC
The same issue still exists with the application not actually working. I had a
lengthy conversation with the author a few months back in an attempt to fix the
issues and it led nowhere.

Comment 7 Rakesh Pandit 2008-09-03 14:35:36 UTC
@Joe
It seems this ticket needs to be closed. Are you still interested.
If no info is provided soon it will be closed.


Note You need to log in before you can comment on or make changes to this bug.