Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236475 - no wait for asynchronous scsi scan.
Summary: no wait for asynchronous scsi scan.
Keywords:
Status: CLOSED DUPLICATE of bug 220470
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 235611
TreeView+ depends on / blocked
 
Reported: 2007-04-14 20:41 UTC by David Woodhouse
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-18 22:45:50 UTC


Attachments (Terms of Use)

Description David Woodhouse 2007-04-14 20:41:00 UTC
The rawhide kernel scans the SCSI bus asynchronously. The initrd doesn't wait
for the scan to complete, after loading a host adapter module. It should,
because otherwise the SCSI drives aren't guaranteed to be present by the time
the final 'mkblkdevs' run happens. And my PS3 doesn't boot...

One way of doing this is to load the 'scan_wait_scan.ko' module. Although that
seems a bit weird to me; I would have thought we could just provide a file in
sysfs where reading or writing would have the same effect.

Comment 1 David Woodhouse 2007-04-18 22:45:50 UTC

*** This bug has been marked as a duplicate of 220470 ***


Note You need to log in before you can comment on or make changes to this bug.