Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236451 - kernel oops with the latest iwlwifi/wireless updates
Summary: kernel oops with the latest iwlwifi/wireless updates
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
: 237182 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-14 13:34 UTC by Roy-Magne Mo
Modified: 2008-03-28 05:09 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-02 20:27:31 UTC


Attachments (Terms of Use)
Snippet from /var/log/messages with BUG (deleted)
2007-04-14 18:07 UTC, Tom London
no flags Details
2.6.21-1.3117.fc7 kernel message log (deleted)
2007-04-28 03:13 UTC, Paul W. Frields
no flags Details

Description Roy-Magne Mo 2007-04-14 13:34:51 UTC
Description of problem:
kernel oops when wireless driver is passing traffic

Version-Release number of selected component (if applicable):
2.6.20-1.3066.fc7

How reproducible:
always

Steps to Reproduce:
1. assosciate with ap and start a ping, seems to happen after 10 seconds
2.
3.
  
Actual results:


Expected results:


Additional info:
I'm not hundred percent sure about how, where and what here - since the logs
seems to fill up with plenty debug messages. I'm happy to supply more details.

BUG: warning at include/asm/dma-mapping.h:25/dma_map_single() (Not tainted)
 [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
 [<c04067ad>] show_trace+0x12/0x14
 [<c0406831>] dump_stack+0x16/0x18
 [<f8b1e847>] d_tx+0x7f2/0xd69 [iwlwifi]
 [<f8a8f6c6>] __ieee80211_tx+0x20/0xec [mac80211]
 [<f8a91588>] ieee80211_master_start_xmit+0x410/0x50e [mac80211]
 [<c05b4352>] dev_hard_start_xmit+0x1ce/0x22b
 [<c05c1e2a>] __qdisc_run+0xdb/0x195
 [<c05b5085>] net_tx_action+0xc2/0xeb
 [<c042bfa7>] __do_softirq+0x6f/0xe2
 [<c0407420>] do_softirq+0x61/0xd0
 [<c042bdd2>] local_bh_enable_ip+0xb9/0xdf
 [<c06161a5>] _spin_unlock_bh+0x25/0x28
 [<f8a9dc86>] ieee80211_scan_completed+0xdf/0x109 [mac80211]
 [<f8a9f0d7>] ieee80211_sta_scan_work+0x63/0x199 [mac80211]
 [<c043510b>] run_workqueue+0x89/0x14e
 [<c0435b21>] worker_thread+0xf8/0x124
 [<c043830f>] kthread+0xb3/0xdc
 [<c0405cd3>] kernel_thread_helper+0x7/0x10
 =======================

Comment 1 Tom London 2007-04-14 18:07:53 UTC
Created attachment 152621 [details]
Snippet from /var/log/messages with BUG

Get this too, 25 seconds after association.

Wireless (even unencrypted) not functioning.

Comment 2 Roy-Magne Mo 2007-04-15 14:23:21 UTC
Exact the same situation with  2.6.20-1.3069.fc7

Comment 3 Jeremy Katz 2007-04-20 15:41:16 UTC
*** Bug 237182 has been marked as a duplicate of this bug. ***

Comment 4 Bryan O'Sullivan 2007-04-24 03:45:50 UTC
I don't get an oops, but the association does get dropped a few seconds after it
initially succeeds, with plenty of log output like this (repeated many times):

iwlwifi: Error sending RXON: time out after 500ms.
iwlwifi: Error clearing ASSOC_MSK on current configuration (-110).
iwlwifi: No space for Tx
iwlwifi: Error sending RXON: ipw_queue_tx_hcmd failed: -28
iwlwifi: Error clearing ASSOC_MSK on current configuration (-28).

I was running 3094 when this happened.  3056 is still the only kernel that works
correctly for me with iwlwifi.

Comment 5 Adam Huffman 2007-04-24 08:00:13 UTC
I have the same symptoms - no Oops but lots of those messages and the connection
fails very soon after the initial success.

Comment 6 John W. Linville 2007-04-25 18:51:36 UTC
Bryan and Adam, I think you should be using bug 236828 instead.

Comment 7 Roy-Magne Mo 2007-04-25 19:40:13 UTC
Just confirming the bug still exists with 2.6.20-1.3104.fc7

Comment 8 Paul W. Frields 2007-04-26 20:48:35 UTC
I'm still seeing the same BUG warning in 2.6.21-1.3116.fc7.


Comment 9 Peter F. Patel-Schneider 2007-04-26 22:05:45 UTC
I'm getting the same sort of problem in F7t4.

I did a full install from the F7t4 Live CD on a ThinkPad T60p with the ipw3945
wireless card.

Comment 10 Jeremy Katz 2007-04-27 17:13:07 UTC
The simple trigger for this is to do a scan while you're associated.  

Comment 11 Paul W. Frields 2007-04-28 03:13:12 UTC
Created attachment 153680 [details]
2.6.21-1.3117.fc7 kernel message log

This is the result under today's 3117 kernel.  I know just about zip about
kernel debugging, but now there's a second BUG happening (see near end of log).
 I don't want to hijack this bug, so if that's unrelated, point me to the right
component; however, the kernel's the only package changed on this machine
between the last attempt and this one.

Comment 12 John W. Linville 2007-04-28 13:50:00 UTC
FWIW, the rtnl_setlink appears to be a different issue (but still in the 
kernel) and should be tracked separately.

Comment 13 drago01 2007-04-30 18:49:40 UTC
some of this issues should be resolved in 0.0.15, see
http://sourceforge.net/mailarchive/forum.php?thread_name=46362924.8040602%40linux.intel.com&forum_name=ipw3945-devel

Comment 14 drago01 2007-05-01 07:48:19 UTC
John, I saw that you updated iwlwifi in cvs to 0.0.15 but 0.0.15 has another
problem: no frames being sent when scanning while acciotated but this is fixed
in the 0.0.16 release ;)

Comment 15 Paul W. Frields 2007-05-01 21:47:44 UTC
This problem looks to be fixed under the 3122 kernel with the new iwlwifi-0.0.16.

Comment 16 Bastien Nocera 2007-05-03 10:16:10 UTC
FYI, the newer kernels are at:
http://people.redhat.com/davej/kernels/Fedora/fc7/kernel.repo


Note You need to log in before you can comment on or make changes to this bug.