Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236441 - [RHEL5 RT] BUG: time warp detected!
Summary: [RHEL5 RT] BUG: time warp detected!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Thomas Gleixner
QA Contact:
URL: http://armstrong.rhts/cgi-bin/rhts/te...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-14 01:25 UTC by Jeff Burke
Modified: 2014-07-25 04:57 UTC (History)
2 users (show)

Fixed In Version: -31
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-03 18:33:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages file (deleted)
2007-05-18 19:24 UTC, Jeff Burke
no flags Details

Description Jeff Burke 2007-04-14 01:25:48 UTC
Description of problem:
 On system ibm-alishan.rhts.boston.redhat.com while running the RHTS testsuite
/kernel/misc/autotest results in the following error: 
 BUG: time warp detected!
 prev > now, 1053bb44a957f108 > 1053bb44676070e6:
 = 1106739234 delta, on CPU#0

Version-Release number of selected component (if applicable):
 2.6.20-14.el5rt

How reproducible:
 50% of the time

Steps to Reproduce:
Here is a link to the kernel
 http://porkchop.redhat.com/brewroot/packages/kernel-rt/2.6.20/14.el5rt/

Here is information on how to setup a local system to use the RHTS devel
environment.

You can down load the tests from here:
http://rhts.lab.boston.redhat.com/rpms/development/noarch/noarch/rh-tests-kernel-misc-autotest-1.0-8.noarch.rpm

This test it written for the RHTS environment. So you can install the
RHTS devel package following the directions from here:
 http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html
then install the test and do a make run.

Or if you do _not_ want to install the RHTS devel stuff comment out the
following:
Makefile
# Include a global make rules file
include /usr/share/rhts/lib/rhts-make.include

runtest.sh
# Source the common test script helpers
. /usr/bin/rhts_environment.sh

then do a make run.
  
Actual results:
<Apr/13 02:44 pm>BUG: time warp detected!
<Apr/13 02:44 pm>prev > now, 1053bb44a957f108 > 1053bb44676070e6:
<Apr/13 02:44 pm>= 1106739234 delta, on CPU#0
<Apr/13 02:44 pm> [<c04051b3>] dump_trace+0x63/0x1eb
<Apr/13 02:44 pm> [<c0405358>] show_trace_log_lvl+0x1d/0x3a
<Apr/13 02:44 pm> [<c0405987>] show_trace+0x12/0x14
<Apr/13 02:44 pm> [<c0405a1a>] dump_stack+0x16/0x18
<Apr/13 02:44 pm> [<c0432d73>] do_gettimeofday+0x159/0x18c
<Apr/13 02:44 pm> [<c042e093>] sys_gettimeofday+0x1d/0x58
<Apr/13 02:44 pm> [<c0404109>] syscall_call+0x7/0xb
<Apr/13 02:44 pm> [<b7ef97f2>] 0xb7ef97f2
<Apr/13 02:44 pm> =======================
<Apr/13 02:44 pm>---------------------------
<Apr/13 02:44 pm>| preempt count: 00000000 ]
<Apr/13 02:44 pm>| 0-level deep critical section nesting:
<Apr/13 02:44 pm>----------------------------------------

Expected results:
 Test should pass

Additional info:

Comment 1 Tim Burke 2007-05-18 15:42:12 UTC
Notes from internal con-call today:

jburke:
- IBM Athlon based system, 500mb mem
- error when running a diversity of kernel stress tests - not exactly sure which
precise test induced it
- repeatable, every time on this one system
- QA took the system for a standard RHEL issue so we can't reproduce immediately.

Recommendation: Ask IBM if they are seeing this and if they have any ideas.


Comment 2 Jeff Burke 2007-05-18 16:04:20 UTC
********** System Information **********
Hostname                = ibm-alishan
Kernel Version          = 2.6.20-14.el5rt
Machine Hardware Name   = i686
Processor Type          = athlon
uname -a output         = Linux ibm-alishan 2.6.20-14.el5rt #1 SMP PREEMPT Fri
Apr 13 10:39:25 EDT 2007 i686 athlon i386 GNU/Linux
Swap Size               = 1023 MB
Mem Size                = 485 MB
Number of Processors    = 2
System Release          = Red Hat Enterprise Linux Server release 5 (Tikanga)
Command Line            = ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200
System NMI Interrupts   = NMI:          0          0 
********** LSPCI **********
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:02.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 21)
********** Modprob **********
alias eth0 tg3
alias scsi_hostadapter sata_nv
********** Module Information **********
Checking module information autofs4:
Checking module information hidp:
Bluetooth HIDP ver 1.1
Checking module information rfcomm:
Bluetooth RFCOMM ver 1.8
Checking module information l2cap:
Bluetooth L2CAP ver 2.8
Checking module information bluetooth:
Bluetooth Core ver 2.11
Checking module information sunrpc:
Checking module information ipv6:
IPv6 protocol stack for Linux
Checking module information cpufreq_ondemand:
'cpufreq_ondemand' - A dynamic cpufreq governor for Low Latency Frequency
Transition capable processors
Checking module information video:
ACPI Video Driver
Checking module information sbs:
Smart Battery System ACPI interface driver
Checking module information i2c_ec:
ACPI EC SMBus driver
Checking module information dock:
ACPI Dock Station Driver
Checking module information button:
ACPI Button Driver
Checking module information battery:
ACPI Battery Driver
Checking module information asus_acpi:
Asus Laptop ACPI Extras Driver
Checking module information backlight:
Backlight Lowlevel Control Abstraction
Checking module information ac:
ACPI AC Adapter Driver
Checking module information lp:
Checking module information floppy:
Checking module information pata_amd:
low-level driver for AMD PATA IDE
Checking module information sg:
SCSI generic (sg) driver
Checking module information cfi_cmdset_0002:
MTD chip driver for AMD/Fujitsu flash chips
Checking module information cfi_util:
Checking module information mtdpart:
Generic support for partitioning of MTD devices
Checking module information parport_pc:
PC-style parallel port driver
Checking module information parport:
Checking module information jedec_probe:
Probe code for JEDEC-compliant flash chips
Checking module information cfi_probe:
Probe code for CFI-compliant flash chips
Checking module information k8temp:
AMD K8 core temperature monitor
Checking module information gen_probe:
Helper routines for flash chip probe code
Checking module information hwmon:
hardware monitoring sysfs/class support
Checking module information ck804xrom:
MTD map driver for BIOS chips on the Nvidia ck804 southbridge
Checking module information tg3:
Broadcom Tigon3 ethernet driver
Checking module information ide_cd:
ATAPI CD-ROM Driver
Checking module information mtdcore:
Core MTD registration and access routines
Checking module information pcspkr:
PC Speaker beeper driver
Checking module information i2c_nforce2:
nForce2/3/4/5xx SMBus driver
Checking module information chipreg:
Core routines for registering and invoking MTD chip drivers
Checking module information cdrom:
Checking module information i2c_core:
I2C-Bus main module
Checking module information serio_raw:
Raw serio driver
Checking module information dm_snapshot:
device-mapper snapshot target
Checking module information dm_zero:
device-mapper dummy target returning zeros
Checking module information dm_mirror:
device-mapper mirror target
Checking module information dm_mod:
device-mapper driver
Checking module information ata_generic:
low-level driver for generic ATA
Checking module information sata_nv:
low-level driver for NVIDIA nForce SATA controller
Checking module information libata:
Library module for ATA devices
Checking module information sd_mod:
SCSI disk (sd) driver
Checking module information scsi_mod:
SCSI core
Checking module information ext3:
Second Extended Filesystem with journaling extensions
Checking module information jbd:
Checking module information ehci_hcd:
10 Dec 2004 USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Checking module information ohci_hcd:
2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
Checking module information uhci_hcd:
USB Universal Host Controller Interface driver

Comment 3 john stultz 2007-05-18 18:48:37 UTC
I know Ingo had a variant of the paranoid timekeeping check included for awhile.
Although I've not been convinced that it didn't throw false positives. 

Few questions: 
1) What type of IBM system is this?
2) Can it be reproduced w/ the current RHEL5-rt kernel?
3) Can you attach dmesg output on the box?


Comment 4 Jeff Burke 2007-05-18 19:23:35 UTC
Few questions: 
1) What type of IBM system is this?
    	IBM eServer x3105 -[434774Z]-
2) Can it be reproduced w/ the current RHEL5-rt kernel?
        System is currently in use by QE for RHEL3-U9 testing. I was hoping that
IBM could try and reproduce it on similar hardware. Once that hardware becomes
available again I will try it.
3) Can you attach dmesg output on the box?
        I don't have a dmesg output I have the /var/log/messages from that
failure. I will attach it to the BZ.

Comment 5 Jeff Burke 2007-05-18 19:24:09 UTC
Created attachment 155026 [details]
/var/log/messages file


Note You need to log in before you can comment on or make changes to this bug.