Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236425 - [RHEL5 RT] IBM rt_check test is failing
Summary: [RHEL5 RT] IBM rt_check test is failing
Keywords:
Status: CLOSED DUPLICATE of bug 236962
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Red Hat Real Time Maintenance
QA Contact:
URL: http://rhts.lab.boston.redhat.com/cgi...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 20:22 UTC by Jeff Burke
Modified: 2008-02-27 19:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 01:57:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jeff Burke 2007-04-13 20:22:57 UTC
Description of problem:
 Running the rt kernel, /kernel/rt-tests/rt_check test fails.

Version-Release number of selected component (if applicable):
 2.6.20-14.el5rt

How reproducible:
 Always

Steps to Reproduce:
1. Install and run the rt_check test from IBM on an 
  
Actual results:
 Test Start Time: Fri Apr 13 15:53:18 EDT 2007
 trying to request real-time scheduling: ok
 trying to lock memory: failed
	RLIMIT_MLOCK is 32768
 testing for high resolution timers: ok (not yet implemented)
 testing for robust (PI) mutexes: ok (not yet fully implemented)
 testing for the rtj12 kernel: failed.
 testing for acceptable clock resolution (<=200us): ok.
 Some tests failed, exiting with status 17
 rt_check Failed: 
 Test End Time: Fri Apr 13 15:53:18 EDT 2007

Expected results:
 This test should pass?

Additional info:
Here is a link to the kernel
 http://porkchop.redhat.com/brewroot/packages/kernel-rt/2.6.20/14.el5rt/

Here is information on how to setup a local system to use the RHTS devel
environment.

You can down load the tests from here:
http://rhts.lab.boston.redhat.com/rpms/development/noarch/noarch/rh-tests-kernel-rt-tests-rt_check-1.0-2.noarch.rpm

This test it written for the RHTS environment. So you can install the
RHTS devel package following the directions from here:
 http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html
then install the test and do a make run.

Or if you do _not_ want to install the RHTS devel stuff comment out the
following:
Makefile
# Include a global make rules file
include /usr/share/rhts/lib/rhts-make.include

runtest.sh
# Source the common test script helpers
. /usr/bin/rhts_environment.sh

then do a make run.

Comment 1 Tim Burke 2007-04-19 01:57:48 UTC

*** This bug has been marked as a duplicate of 236962 ***


Note You need to log in before you can comment on or make changes to this bug.