Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236424 - [RHEL5 RT] GPL / NonGPL Module testing fails on x86_64
Summary: [RHEL5 RT] GPL / NonGPL Module testing fails on x86_64
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Don Zickus
QA Contact:
URL: http://rhts.lab.boston.redhat.com/cgi...
Whiteboard:
Depends On: 253476
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 20:17 UTC by Jeff Burke
Modified: 2008-02-27 19:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-12 18:41:21 UTC


Attachments (Terms of Use)

Description Jeff Burke 2007-04-13 20:17:31 UTC
Description of problem:
RHTS test /kernel/drivers/3rd-party fail on x86_64

Version-Release number of selected component (if applicable):
 2.6.20-14.el5rt

How reproducible:
 Always

Steps to Reproduce:
1. Run the /kernel/drivers/3rd-party on x86_64
  
Actual results:
 Kernel is not tainted at this time
 Running GPLModule
 Module installed: GPLModule 
 Kernel is not tainted at this time
 GPLModule test Failed:

Expected results:
 This test should pass

Additional info:
 With the same kernel version this test works on i386 but fails on x86_64.

Test that passes:
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/recipes.cgi?id=73492


###############################################################################
Here is a link to the kernel
 http://porkchop.redhat.com/brewroot/packages/kernel-rt/2.6.20/14.el5rt/

Here is information on how to setup a local system to use the RHTS devel
environment.

You can down load the tests from here:
http://rhts.lab.boston.redhat.com/rpms/development/noarch/noarch/rh-tests-kernel-drivers-3rd-party-1.9-10.noarch.rpm

This test it written for the RHTS environment. So you can install the
RHTS devel package following the directions from here:
 http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html
then install the test and do a make run.

Or if you do _not_ want to install the RHTS devel stuff comment out the
following:
Makefile
# Include a global make rules file
include /usr/share/rhts/lib/rhts-make.include

runtest.sh
# Source the common test script helpers
. /usr/bin/rhts_environment.sh

then do a make run.

Comment 1 Jeff Burke 2007-05-22 13:21:06 UTC
This is failing in the latest kernel 2.6.21-11.el5rt:

/kernel/drivers/3rd-party
Completed - Fail
	GPLModule 	Fail 	0
	NonGPLModule 	Fail 	0
	BadModuleSign 	Pass 	0
	GoodModuleSign 	Pass 	0

http://rhts.lab.boston.redhat.com/cgi-bin/rhts/jobs.cgi?id=773&type=Single
Recipe 2854



Comment 3 David Howells 2007-07-23 14:08:00 UTC
This may be due to the test script making assumptions about its operating 
environment:

 (1) /proc/sys/kernel/print-fatal-signals does not appear to exist in the 
kernel specified, yet CheckUnsignModule() attempts to make use of it.

 (2) The killme.sh script does not appear to leave anything in the dmesg log, 
but CheckUnsignModule() appears to rely on it saying something.

What kernel were these scripts meant to test?

Comment 4 Don Zickus 2007-07-23 14:44:55 UTC
These scripts were designed for RHEL-5.  The execshield patch puts the
print-fatal-signals functionality into the kernel.  So yeah, if the kernel
doesn't have print-fatal-signal, the test won't do much.  Unless someone has
another way to detect if a 'bad' kernel module tainted the kernel using a
userspace app?

Comment 5 Jon Masters 2007-08-20 07:28:21 UTC
Like 253476 perhaps.

Jon.


Comment 6 Jeff Burke 2007-10-17 16:00:05 UTC
Jon,
   Do we have any additional data on this issue? Are we going to try and fix it
for RT?

Jeff

Comment 8 Don Zickus 2007-10-17 17:21:21 UTC
Jeff,

This test is really RHEL-5 specific.  We should be able to modify it to utilize
the output of /proc/modules now.  Upstream added a patch to display the taint
flags to that proc file.   I am working with Jon to backport this to RHEL-5 so
we can better test across all the arches.  Once those changes are in, we can
modify the script to take advantage of the proc file and then the test should
automatically become forward compatible (with RT/RHEL-6, etc).

Comment 9 Clark Williams 2008-02-06 16:41:41 UTC
Where do we stand on this bug, wrt RT?

Comment 10 Jeff Burke 2008-02-12 18:41:21 UTC
Clark,
  As discusses on IRC and verbally. This test is of no value to the RT kernel

Jeff


Note You need to log in before you can comment on or make changes to this bug.