Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236413 - compile with --enable-libusb
Summary: compile with --enable-libusb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pilot-link
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 18:07 UTC by James Ralston
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-17 11:28:41 UTC


Attachments (Terms of Use)
Fix BuildRequires to enable libusb support (deleted)
2007-07-25 18:00 UTC, Steven Pritchard
no flags Details | Diff
path for Sony Clie NR70 compatibility (deleted)
2007-07-27 20:54 UTC, Serguei Miridonov
no flags Details | Diff

Description James Ralston 2007-04-13 18:07:21 UTC
Version 0.12.0 of pilot-link, released on 2006-09-04, includes native USB
support if compiled with --enable-libusb.

Native USB is very desirable, because it avoids all sorts of problems that arise
using the visor kernel module.  (For the gory details, see bug 158809; in
particular see comment 34 of bug 158809.)

I note that the version of pilot-link that is in Rawhide (and presumably, that
will be in Fedora 7) is 0.12.1.  However, it isn't compiled with --enable-libusb.

Please compile pilot-link with --enable-libusb, and work with the udev et. al.
maintainers to get native USB support working.

I have been testing native USB support for months (by rolling by own pilot-link
RPM compiled with --enable-libusb); I would be happy to help test this change.

Comment 1 James Ralston 2007-04-13 18:12:05 UTC
(See also bug 187410, where --enable-libusb was previously requested.)


Comment 2 Ivana Varekova 2007-04-16 10:12:20 UTC
Thanks.
--enable-libusb is just added. I plan to work on pilot-link soon so there should
be some improvement shortly.

Comment 3 James Ralston 2007-05-02 17:14:53 UTC
Thanks.  I'll attempt to figure out what udev magic is necessary to get the
/dev/bus/usb devices files owned by the console user for Palm devices.


Comment 4 James Ralston 2007-06-13 21:56:43 UTC
Although the SPEC file now uses --enable-libusb, the actual packages in Fedora
Development don't have native USB support.

Most likely, the libusb-devel package isn't installed on the build system.  (You
need both use --enable-libusb and have libusb-devel installed in order to get
native USB support.)

Per doc/README.libusb, if you don't see this exact line in the ./configure
summary page:

    Direct USB support...... : yes, libusb

...then you don't have native USB support.

To test for native USB support at runtime, run:

$ pilot-xfer -p usb: -l

You should see:

   Listening for incoming connection on usb:... 

If you receive an error about not being able to bind to "usb:", then you don't
have native USB support.


Comment 5 Serguei Miridonov 2007-07-21 02:28:45 UTC
I'm second to this request. Please, enable libusb support as soon as possible.

Comment 6 Steven Pritchard 2007-07-25 18:00:42 UTC
Created attachment 159967 [details]
Fix BuildRequires to enable libusb support

Without BuildRequires: libusb-devel, libusb isn't really enabled.  With the
spec patch applied, I can connect to a Treo 700p with "pilot-xfer -p usb:".

Comment 7 Serguei Miridonov 2007-07-25 18:13:29 UTC
Anybody from Fedora support, could you please apply this patch and push updated 
version for testing? New kernel 2.6.22.1-33.fc7 fixes some USB problems 
appeared since 2.6.22.1-20.fc7 and now libusb seems to be working again.

Comment 8 Ivana Varekova 2007-07-27 11:40:22 UTC
pilot-link-0.12.2-3.fc7 was just build and pushed to testing branch.

Comment 9 Serguei Miridonov 2007-07-27 20:54:50 UTC
Created attachment 160141 [details]
path for Sony Clie NR70 compatibility

This patch is required for original pilot-link 0.12.2 to work with Sony Clie
NR70. Bug report submitted also to http://bugs.pilot-link.org/view.php?id=1830

Comment 10 Fedora Update System 2007-07-30 16:58:55 UTC
pilot-link-0.12.2-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Serguei Miridonov 2007-07-31 14:55:38 UTC
pilot-link-0.12.2-3.fc7 does not work with Sony Clie NR70. I believe this 
version, like the original pilot-link 0.12.2, needs this patch: https://
bugzilla.redhat.com/bugzilla/attachment.cgi?id=160141

Additional info:

kernel-2.6.22.1-33.fc7
udev-113-7.fc7

However, please note, the maintainer of pilot-link still did not reply for my 
bug report. In fact, if I'm the only one who has this problem, this is not 
urgent, because I have applied this patch to the original pilot-link and copied 
libpisock libraries to /usr/lib to replace these files from Fedora package. 
After that pilot-* programs are working in my computer. So, I would wait the 
reply from maintainer of pilot-link to see if he accepts this patch or offers 
another resolution for this problem.

Comment 12 James Ralston 2007-08-01 22:23:27 UTC
pilot-link-0.12.2-3.fc7 is properly linked with direct libusb support, yes.  Thanks.

Comment 13 Ivana Varekova 2007-08-22 14:15:32 UTC
Thanks Serguei Miridonov for your comment and patch, I will wait till upstream
enclose this patch to upstream cvs. I can't reproduce your problem myself, so I
think it would be better this way. 
The main problem (usb support) is solved, so I'm closing this bug.

Comment 14 Alex Lancaster 2007-09-14 08:54:27 UTC
(In reply to comment #13)
> Thanks Serguei Miridonov for your comment and patch, I will wait till upstream
> enclose this patch to upstream cvs. I can't reproduce your problem myself, so I
> think it would be better this way. 
> The main problem (usb support) is solved, so I'm closing this bug.

Can you please go to bodhi and "push" the update from updates-testing to updates
(i.e. stable)?  This needs to be done manually, it's been sitting in
updates-testing for almost 2 months:

https://admin.fedoraproject.org/updates/testing/F7/pilot-link-0.12.2-3.fc7

comment #13 already indicated that it fixes the original bug and bodhi closes
the bug automatically once it's pushed to updates, so I'm reopening until such
time as it is pushed to updates.

Thanks.

Comment 15 Ivana Varekova 2007-09-17 11:28:41 UTC
Done.

Comment 16 Fedora Update System 2007-09-18 03:24:24 UTC
pilot-link-0.12.2-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.