Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236404 - GFS2 requires a minimum lock hold time for glocks
Summary: GFS2 requires a minimum lock hold time for glocks
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Whitehouse
QA Contact: Dean Jansa
URL:
Whiteboard:
Depends On: 235697
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 16:33 UTC by Nate Straz
Modified: 2009-05-28 03:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-25 13:43:39 UTC


Attachments (Terms of Use)

Description Nate Straz 2007-04-13 16:33:21 UTC
+++ This bug was initially created as a clone of Bug #235697 +++

To solve the performance problems seen with the alternate test and similar
contention cases, we need to implement some kind of minimum lock hold time to
ensure that the cluster makes progress even in heavy lock traffic.

Probably we need a user configurable, but with a sensible default, setting which
puts a maximum cap on the minimum lock hold time, and then try to set the lock
hold time automatically using information gathered from the system, such as how
long the wait has been when acquiring the lock, how much work needs to be done, etc.

Comment 1 RHEL Product and Program Management 2007-04-13 18:04:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Steve Whitehouse 2007-06-05 13:06:56 UTC
This has missed 5.1, so retarget for 5.2?

Comment 3 Steve Whitehouse 2007-08-25 13:43:39 UTC

*** This bug has been marked as a duplicate of 248480 ***


Note You need to log in before you can comment on or make changes to this bug.