Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236400 - Underscores shown in colour preferences
Summary: Underscores shown in colour preferences
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-13 16:08 UTC by Andrew Overholt
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 03:04:01 UTC


Attachments (Terms of Use)
illustrative screenshot (deleted)
2007-04-13 16:08 UTC, Andrew Overholt
no flags Details

Description Andrew Overholt 2007-04-13 16:08:29 UTC
Underscores are shown in Edit -> Preferences -> Mail Preferences -> Colours. 
See screenshot.  I don't *think* this is intentional but I guess it could be.

Comment 1 Andrew Overholt 2007-04-13 16:08:30 UTC
Created attachment 152554 [details]
illustrative screenshot

Comment 2 Christopher Aillon 2007-04-17 19:03:17 UTC
Should be relatively simple and nice to have for F7.

Comment 3 Milan Crha 2007-04-25 15:14:49 UTC
I think this is not a bug. You could rename colors, so you could give them your
own meaning. The underscore is used to mark an accelerator in menu, (like right
click over a message and choose Label submenu), I think you need to see these
underscores and an ability to change a meaning of the color is advantage as well.
But I may miss something, could you write here the result, which you expect?
(May be changing all predefined names without underscores, but it's against
accelerators in menu)

Comment 4 Matthias Clasen 2007-04-28 15:18:22 UTC
I'd say that this is not a bug

Comment 5 Andrew Overholt 2007-04-28 18:04:04 UTC
I don't see how the underscores are supposed to be known to non-programmers. 
But I will not protest.

Comment 6 Matthew Barnes 2007-04-28 18:39:28 UTC
Underscores or not, it would be helpful to add some verbage to that tab
explaining what those options do.  It's not very intuitive.  But this is
upstream's problem anyway, I suppose.

Comment 7 Matthias Clasen 2007-05-03 01:59:50 UTC
Yeah, not worth carrying a fedora patch for.

Comment 8 Matthias Clasen 2007-05-03 12:57:20 UTC
It is also somewhat odd that there is an extra configuration tab for the colors
and labels, but no way to add additional colors/labels. The whole thing looks
very obviously extensible, unless there is some wierd interoperability
constraint with exchange or something like that preventing it...

Comment 9 Matthias Clasen 2007-05-08 03:02:53 UTC
Filed upstream: http://bugzilla.gnome.org/show_bug.cgi?id=436762


Note You need to log in before you can comment on or make changes to this bug.