Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236399 - Reply reverses month and day
Summary: Reply reverses month and day
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-13 16:05 UTC by Andrew Overholt
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: evolution-2.10.1-8.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-28 04:52:58 UTC


Attachments (Terms of Use)
illustrative screenshot of the two dates (deleted)
2007-04-13 16:05 UTC, Andrew Overholt
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 434019 None None None Never

Description Andrew Overholt 2007-04-13 16:05:37 UTC
Hitting reply results in the attribution string having the month and day
reversed.  Example:

Fri, 09 Mar 2007

=> "On Fri, 2007-09-03 ..."

That should read "On Fri, 2007-03-09 ..."

I'm running under en_CA.  See the screenshot.

Comment 1 Andrew Overholt 2007-04-13 16:05:37 UTC
Created attachment 152553 [details]
illustrative screenshot of the two dates

Comment 2 Matthew Barnes 2007-04-27 18:13:09 UTC
The attribution string is localized, whereas I believe the Date field in the
original message is displayed as is.

po/en_CA.po
-----------

#. Note to translators: this is the attribution string used when quoting
#. * messages. Each ${Variable} gets replaced with a value. To see a full
#. * list of available variables, see em-composer-utils.c:1514
#: ../mail/em-composer-utils.c:1705
msgid ""
"On ${AbbrevWeekdayName}, ${Year}-${Month}-${Day} at ${24Hour}:${Minute} "
"${TimeZone}, ${Sender} wrote:"
msgstr ""
"On ${AbbrevWeekdayName}, ${Year}-${Day}-${Month} at ${24Hour}:${Minute} "
"${TimeZone}, ${Sender} wrote:"


Comment 3 Matthew Barnes 2007-04-27 18:19:04 UTC
Closing this as NOTABUG since it seems to be the intended behavior, but feel
free to reopen this if you feel there's an issue with that behavior.

Comment 4 Andrew Overholt 2007-04-27 22:10:30 UTC
That is *definitely* a bug.  Can we fix it in our packages until Adam W. (I
assume he still does the translations) gets a chance to fix upstream?  A simple
reversal of the ${Day} and ${Month} in msgstr would be perfect, I think.  Thanks.

Comment 5 Matthew Barnes 2007-04-28 04:52:58 UTC
No problem.  Fixed in evolution-2.10.1-8.fc7.

Also forwarded this upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=434019


Note You need to log in before you can comment on or make changes to this bug.