Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236396 - Sometimes evolution does not recognize attachments
Summary: Sometimes evolution does not recognize attachments
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 15:55 UTC by Emmanuel Kowalski
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-18 14:45:43 UTC


Attachments (Terms of Use)
Sample email (deleted)
2007-10-07 07:02 UTC, Emmanuel Kowalski
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 487922 None None None Never

Description Emmanuel Kowalski 2007-04-13 15:55:01 UTC
Description of problem:
In some emails I have received recently which contained attachments,
evolution only identified them as ``unknown attachment'', instead
of PDF, etc. 

Version-Release number of selected component (if applicable):
beagle-evolution-0.2.13-1.fc6.i386.rpm
evolution-2.8.3-2.fc6.i386.rpm
evolution-data-server-1.8.3-4.fc6.i386.rpm
evolution-data-server-devel-1.8.3-4.fc6.i386.rpm
evolution-sharp-0.11.1-10.fc6.i386.rpm
evolution-webcal-2.7.1-6.i386.rpm


How reproducible:
It seems to be correlated with senders using Apple Mail (all examples use
Apple Mail 2.752.3 or 2.619). I am not sure if all Apple Mail emails with
attachments have this issue, and older ones may work better, so that it might 
be a recent regression. (Specifically, the cutoff seems to be around the end
of January / beginning of February; there was an evolution update on
Feb. 12).

Steps to Reproduce:
Not clear how to reproduce this directly.
  
Actual results:
Unreadable attachments.

Expected results:
Readable attachments.

Additional info:
I can provide sample emails which cause problem.

Comment 1 Emmanuel Kowalski 2007-04-13 15:57:14 UTC
I forgot to indicate that seamonkey has no trouble seeing all attachments,
as does the Horde webmail system, so it does not seem to be a matter of 
malformed incoming messages.

Comment 2 Emmanuel Kowalski 2007-04-13 16:17:36 UTC
Here is an update/workaround: the issue seems to be related to the
display of HTML messages as _plain text_. Specifically, I was setting
the configuration item ``Mail preferences/HTML Mail/Plain Text Mode'' to
``Prefer plain''. If I switch to ``Show HTML if present'', the attachments
display normally and are opened correctly.

Also, it is not a recent regression: I tested 
evolution-2.2.3-4.fc4.i386.rpm
on an FC4 system, and the same problem/workaround apply.


Comment 3 Matthew Barnes 2007-10-05 04:09:38 UTC
Thanks for the update from a few months ago and apologies for not getting to
your bug until now.  Can you still reproduce this problem on Fedora 7 or later,
and if so could you post a sample mail containing one of these problematic
attachments so that I can try to reproduce the problem?

Comment 4 Emmanuel Kowalski 2007-10-05 08:16:38 UTC
I have not update to FC7 (waiting for FC8).  However, I may have time to try
with a LiveCD this weeked.
I will attach a simple test message that shows the problem in the current
versions for FC6.

[root@semillon ~]# grep evol /var/log/rpmpkgs
beagle-evolution-0.2.13-1.fc6.i386.rpm
evolution-2.8.3-2.fc6.i386.rpm
evolution-data-server-1.8.3-7.fc6.i386.rpm
evolution-data-server-devel-1.8.3-7.fc6.i386.rpm
evolution-sharp-0.11.1-10.fc6.i386.rpm
evolution-webcal-2.7.1-6.i386.rpm



Comment 5 Emmanuel Kowalski 2007-10-05 08:31:15 UTC
At the moment I am unable to create myself a problematic message.  Those I have
in my mailbox are rather large and contain somewhat private information.  I will
try to get a test case over the week-end.


Comment 6 Emmanuel Kowalski 2007-10-06 16:58:23 UTC
I have tried the LiveCD version of FC 8 (Fedora 7.92 LiveCD i386) today,
and the problem is still present with:

[root@localhost tmp]# rpm -qa|grep evolution
evolution-webcal-2.12.0-1.fc8
evolution-data-server-1.12.0-1.fc8
evolution-2.12.0-3.fc8

The workaround (display HTML mail) still works.

Also, looking at other evolution bugs, this may be a duplicate of 239148, since
my problematic mails are also produced by Apple Mail, and I have been unable so
far to create a problem email using either Seamonkey, the Horde Webmail, or
Evolution itself.  

I will add a comment to the bug 239148 to suggest the workaround, and try to
access a Mac to create a sample email with the problem.


Comment 7 Matthew Barnes 2007-10-06 22:24:39 UTC
Thanks for responding.  A sample email would be of great help!

Comment 8 Emmanuel Kowalski 2007-10-07 07:02:30 UTC
Created attachment 218581 [details]
Sample email

This is a sample problematic email obtained by modifying one of mine.  It
exhibits the problem at least on FC6 (I haven't tried again on the LiveCD, but
can do so if needed).  It contains a single attachment which is a small PDF
file.

Comment 9 Milan Crha 2007-10-18 14:45:43 UTC
Thanks for data.
Moving this upstream where we will continue to track the problem.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=487922



Note You need to log in before you can comment on or make changes to this bug.