Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236393 - face browser shows no faces
Summary: face browser shows no faces
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: David Lawrence
URL:
Whiteboard:
: 179828 240257 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-13 15:51 UTC by Andrew Overholt
Modified: 2007-11-30 22:12 UTC (History)
5 users (show)

Fixed In Version: 2.18.0-18.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 19:43:01 UTC


Attachments (Terms of Use)
control-center-2.18.0-set-face-perms.patch (deleted)
2007-04-27 15:29 UTC, Bastien Nocera
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 433898 None None None Never

Description Andrew Overholt 2007-04-13 15:51:32 UTC
If I set my face icon preference in the About Me app, it's not shown in gdm.  Is
this expected?  I'm just using a stock face icon from /usr/share/pixmaps/faces
(or wherever).

gdm-2.18.0-10.fc7.i386

Comment 1 David Zeuthen 2007-04-15 02:17:04 UTC
The face needs to have permission 755 IIRC - does that work?

Comment 2 Andrew Overholt 2007-04-15 03:51:57 UTC
Everything in /usr/share/pixmaps/faces is 755 and it's one of those that I'm
picking.

Comment 3 David Zeuthen 2007-04-15 03:55:22 UTC
Setting a face involves copy that file to ~/.face - what's the permission there?
My guess is that "About Me" gets it wrong there...


Comment 4 Andrew Overholt 2007-04-16 14:46:52 UTC
Yeah, that's what the problem was.  If I chmod 755 ~/.face it works.

Comment 5 David Zeuthen 2007-04-16 16:03:05 UTC
OK, reassigning to control-center then - the "About Me" dialog needs to set the
correct mode on ~/.face.

Comment 6 Matthias Clasen 2007-04-17 13:06:00 UTC
Looking at gdm_get_facefile_from_home(), ~/.face will also not work on

a) automounted homedirs
b) nfs homedirs

It would probably be better to switch to using GlobalFaceDir. Of course, that adds
complication to storing the face in the about-me capplet.

Comment 7 Bastien Nocera 2007-04-19 16:28:35 UTC
Andrew, do you use a umask different from the default one? Do you remember what
the permissions were on that file before you changed them?

What were the permissions on your home directory as well?

Comment 8 Andrew Overholt 2007-04-19 17:08:40 UTC
I installed this machine with the test2 live cd and haven't messed with the
default umask. I think the permissions were rw-rw-r-- IIRC.  My home directory
is rwx------.

If I remove ~/.face, will things go back to how they were before for us to check?

Comment 9 Andrew Overholt 2007-04-19 17:09:46 UTC
I forgot that I didn't format my /home partition so it may have some wacky
settings from the old installations.  Could that be it?  I really don't think
I've changed umasks before, though.

Comment 10 Bastien Nocera 2007-04-27 15:15:40 UTC
I could reproduce this on my laptop. In the log I see:
Apr 27 16:02:42 snoogens gdm[3369]: run_pictures: /home/hadess/.face is writable
by group.

In the code this is:
    /* ... if group has write permission ... */
    if G_UNLIKELY (perms < 1 && (statbuf.st_mode & S_IWGRP) == S_IWGRP) {
        syslog (LOG_WARNING, _("%s: %s is writable by group."), caller, dir);
        return FALSE;
    }
(in daemon/filecheck.c)

this function is called from check_user_file(), itself called from
gdm_get_facefile_from_home() (both in gdmconfig.c)

So we need to make sure the file isn't writable by the group, or remove the
check from gdm. I did a chmod on my ~/.face to 755 and it works fine.

Comment 11 Bastien Nocera 2007-04-27 15:29:05 UTC
Created attachment 153629 [details]
control-center-2.18.0-set-face-perms.patch

Untested patch. Ray, could you test and apply?

Comment 12 Matthias Clasen 2007-04-27 23:43:22 UTC
Patch looks good to me.

Comment 13 Bastien Nocera 2007-04-30 08:12:27 UTC
*** Bug 179828 has been marked as a duplicate of this bug. ***

Comment 14 Bastien Nocera 2007-04-30 17:54:11 UTC
The latest version that got applied upstream should apply with a bit of fuzz:
http://bugzilla.gnome.org/attachment.cgi?id=87277&action=view

Comment 15 Bastien Nocera 2007-05-01 09:47:26 UTC
Fixed in control-center-2.18.0-15.fc7

Comment 16 Bastien Nocera 2007-05-16 08:43:42 UTC
*** Bug 240257 has been marked as a duplicate of this bug. ***

Comment 17 Sertaç Ö. Yıldız 2007-05-22 15:40:26 UTC
not that i'm hit by this bug, but it looks like the fix is only included in the
package, not actually applied.

http://cvs.fedora.redhat.com/viewcvs/rpms/control-center/devel/control-center.spec?r1=1.248&r2=1.249

Comment 18 Jeremy Katz 2007-05-22 19:26:32 UTC
Applied and built now

Comment 19 Bastien Nocera 2007-05-22 19:43:01 UTC
Thanks Sertaç for the notice.
Really fixed in control-center-2.18.0-18.fc7


Note You need to log in before you can comment on or make changes to this bug.