Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236388 - numlock on at login with T42 and no way to turn it off
Summary: numlock on at login with T42 and no way to turn it off
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 15:32 UTC by Andrew Overholt
Modified: 2018-04-11 12:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-04 13:40:02 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2007-04-16 14:39 UTC, Andrew Overholt
no flags Details
Xorg.0.log (deleted)
2007-04-16 14:40 UTC, Andrew Overholt
no flags Details
Xorg.1.log (deleted)
2007-04-16 14:41 UTC, Andrew Overholt
no flags Details
Xorg.20.log (deleted)
2007-04-16 14:41 UTC, Andrew Overholt
no flags Details
Xorg.0.log after moving /etc/X11/xorg.conf out of the way (deleted)
2007-04-16 14:44 UTC, Andrew Overholt
no flags Details

Description Andrew Overholt 2007-04-13 15:32:19 UTC
I'm sorry, but I really don't know where to file this.  When I boot up, numlock
is off.  When I log in, it turns on and I can't turn it off.  I have to
Ctrl-Alt-F1 and then Alt-F7 back to get it to go off.

This is on my T42.

$ rpm -q gdm xorg-x11-drv-ati; uname -r; sudo grep -ir num /etc/X11/*
gdm-1:2.18.0-10.fc7.i386
xorg-x11-drv-ati-6.6.3-2.fc7.i386
2.6.20-1.3062.fc7
Binary file /etc/X11/X matches
$

Comment 1 Matěj Cepl 2007-04-16 14:05:20 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Andrew Overholt 2007-04-16 14:39:15 UTC
Created attachment 152689 [details]
xorg.conf

Comment 3 Andrew Overholt 2007-04-16 14:40:15 UTC
Created attachment 152691 [details]
Xorg.0.log

Comment 4 Andrew Overholt 2007-04-16 14:41:02 UTC
Created attachment 152692 [details]
Xorg.1.log

Comment 5 Andrew Overholt 2007-04-16 14:41:38 UTC
Created attachment 152693 [details]
Xorg.20.log

Comment 6 Andrew Overholt 2007-04-16 14:44:13 UTC
Created attachment 152695 [details]
Xorg.0.log after moving /etc/X11/xorg.conf out of the way

That's all of them, I believe.

Comment 7 Beni Bruno 2007-04-24 07:44:38 UTC
Hi everyone, i face the same problem on my t43, however i found two ways of
getting around the problem, might be of help until the issue is resolved.
Firstly, numlock can be turned off by pressing [Shift]+[NumLock], even though
that makes no sense and the LED stays lit. Secondly, NumLock only locks to on if
you have a lan cable plugged in and your linux (in my case fedora core 6)
requests an IP adress while booting. unplugging the cable during bootup and then
replugging and requesting an IP adress after logging in works fine but feels
quite cumbersome :P

Comment 8 Bug Zapper 2008-04-04 00:04:35 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 9 Andrew Overholt 2008-04-04 13:40:02 UTC
I no longer have this problem (F8).


Note You need to log in before you can comment on or make changes to this bug.