Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236373 - [RHEL5 RT] [tg3] tg3 driver not working as expected
Summary: [RHEL5 RT] [tg3] tg3 driver not working as expected
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: keith mannth
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 14:32 UTC by Jeff Burke
Modified: 2008-02-27 19:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-30 15:17:15 UTC


Attachments (Terms of Use)

Description Jeff Burke 2007-04-13 14:32:40 UTC
Description of problem:
 On several systems IBM eServer BladeCenter LS20 -[885011Z]-, IBM BladeCenter
HS20 -[884321Z]- Driver loads but link is never detected. Both types of systems
have dual Broadcom Corporation NetXtreme BCM5704S Gigabit Ethernet (rev 10)
network cards.

Logs:
 http://rhts.lab.boston.redhat.com/cgi-bin/rhts/system.cgi?id=60
 http://rhts.lab.boston.redhat.com/cgi-bin/rhts/system.cgi?id=76
 http://rhts.lab.boston.redhat.com/cgi-bin/rhts/system.cgi?id=110

Version-Release number of selected component (if applicable):
 2.6.20-12.el5rt

How reproducible:
 Always

Steps to Reproduce:
1. Install kernel on above systems
  
Actual results:
 The systems installs fine with RHEL5 GA, Once the RT kernel boots they no
longer see link.

**********************************************************************
ACPI: PCI interrupt for device 0000:05:01.1 disabled
ACPI: PCI interrupt for device 0000:05:01.0 disabled

tg3.c:v3.72 (January 8, 2007)
ACPI: PCI Interrupt 0000:05:01.0[A] -> GSI 77 (level, low) -> IRQ 77
eth0: Tigon3 [partno(BCM95704A41) rev 2100 PHY(serdes)]
(PCIX:133MHz:64-bit) 1000Base-SX Ethernet 00:0d:60:5b:94:98
eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] Split[0] WireSpeed[0]
TSOcap[0]
eth0: dma_rwctrl[769f4000] dma_mask[64-bit]
ACPI: PCI Interrupt 0000:05:01.1[B] -> GSI 78 (level, low) -> IRQ 78
eth1: Tigon3 [partno(BCM95704A41) rev 2100 PHY(serdes)]
(PCIX:133MHz:64-bit) 1000Base-SX Ethernet 00:0d:60:5b:94:99
eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[0]
TSOcap[1]
eth1: dma_rwctrl[769f4000] dma_mask[64-bit]
PM: Writing back config space on device 0000:05:01.0 at offset b (was
164814e4, writing 2e81014)
PM: Writing back config space on device 0000:05:01.0 at offset 3 (was
804000, writing 804010)
PM: Writing back config space on device 0000:05:01.0 at offset 2 (was
2000000, writing 2000010)
PM: Writing back config space on device 0000:05:01.0 at offset 1 (was
2b00000, writing 2b00146)
PM: Writing back config space on device 0000:05:01.0 at offset 0 (was
164914e4, writing 16a814e4)
ADDRCONF(NETDEV_UP): eth0: link is not ready
PM: Writing back config space on device 0000:05:01.1 at offset b (was
164814e4, writing 2e81014)
PM: Writing back config space on device 0000:05:01.1 at offset 3 (was
804000, writing 804010)
PM: Writing back config space on device 0000:05:01.1 at offset 2 (was
2000000, writing 2000010)
PM: Writing back config space on device 0000:05:01.1 at offset 1 (was
2b00000, writing 2b00146)
PM: Writing back config space on device 0000:05:01.1 at offset 0 (was
164914e4, writing 16a814e4)
ADDRCONF(NETDEV_UP): eth1: link is not ready
PM: Writing back config space on device 0000:05:01.0 at offset b (was
164814e4, writing 2e81014)
PM: Writing back config space on device 0000:05:01.0 at offset 3 (was
804000, writing 804010)
PM: Writing back config space on device 0000:05:01.0 at offset 2 (was
2000000, writing 2000010)
PM: Writing back config space on device 0000:05:01.0 at offset 1 (was
2b00000, writing 2b00146)
PM: Writing back config space on device 0000:05:01.0 at offset 0 (was
164914e4, writing 16a814e4)
PM: Writing back config space on device 0000:05:01.1 at offset b (was
164814e4, writing 2e81014)
PM: Writing back config space on device 0000:05:01.1 at offset 3 (was
804000, writing 804010)
PM: Writing back config space on device 0000:05:01.1 at offset 2 (was
2000000, writing 2000010)
PM: Writing back config space on device 0000:05:01.1 at offset 1 (was
2b00000, writing 2b00146)
PM: Writing back config space on device 0000:05:01.1 at offset 0 (was
164914e4, writing 16a814e4)
**********************************************************************

Expected results:
 System should work as expected.

Additional info:
 This seems to be caused by the tg3 priority fix that was added to the build
 See thread mail on rhel-rt-kernel "Kernel 2.6.20-12.el5rt tg3 driver issues"

Comment 1 keith mannth 2007-04-13 18:13:43 UTC
If you revert the patch then the tg3 link works?  

  Sorry I had not tested with the RHEL kernel + tg3 as of yet as there is other
unexplained behavior which seemed to mask tg3 issue all together. I had only
sent the patch out for RFC and had only tested with 2.6.21-rt[something]. 

 I will have a look on an LS20.  

Comment 2 Clark Williams 2007-04-13 18:50:27 UTC
Keith,

Yes, we reverted the tg3 patch and the link worked. The patch works fine on
single tg3 systems (at least all the ones I've tried). Only seems to fail on
dual/multi-NIC systems. 

Clark


Comment 3 Clark Williams 2007-04-30 15:17:15 UTC
Closing as duplicate of the original tg3 hack bug

*** This bug has been marked as a duplicate of 228563 ***


Note You need to log in before you can comment on or make changes to this bug.