Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236356 - realtime interface for rsyslog
Summary: realtime interface for rsyslog
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 12:53 UTC by Peter Vrabec
Modified: 2008-01-22 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-22 02:36:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
solution based on audit-dispatcher from audit package (deleted)
2007-04-13 13:04 UTC, Peter Vrabec
no flags Details | Diff
sample dispatcher. It can be started by syslogd via -D option. (deleted)
2007-04-13 13:09 UTC, Peter Vrabec
no flags Details

Description Peter Vrabec 2007-04-13 12:53:17 UTC
Description of problem:
Create realtime interface for syslogd. Syslogd will be able to start another 
program and send log messages to stdin of this new process.

Comment 1 Peter Vrabec 2007-04-13 13:04:00 UTC
Created attachment 152537 [details]
solution based on audit-dispatcher from audit package

- syslogd can be run with "-D" option
- "-D" is followed by program, which is started as dispatcher
- dispatcher reads certain messages from stdin
- to specify, which messages are sent to dispatcher, man use "!dispatcher"
directive in /etc/syslog.conf

Comment 2 Peter Vrabec 2007-04-13 13:09:25 UTC
Created attachment 152539 [details]
sample dispatcher. It can be started by syslogd via -D option.

Comment 3 Peter Vrabec 2007-04-13 13:12:59 UTC
I'm looking forward any comments and ideas.

Comment 5 Peter Vrabec 2007-04-16 19:48:35 UTC
sysklogd-1.4.2-5.fc7 was built with this feature.

Comment 12 Daniel Riek 2007-10-04 15:32:08 UTC
This is going to be addressed via rsyslog. Please see bug 250581 for details.

Comment 13 Suzanne Yeghiayan 2008-01-22 02:36:37 UTC

*** This bug has been marked as a duplicate of 178855 ***


Note You need to log in before you can comment on or make changes to this bug.