Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236348 - Packaging causes unsolvable dependencies [NEEDINFO]
Summary: Packaging causes unsolvable dependencies
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdnssd-avahi
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 12:04 UTC by Zenon Panoussis
Modified: 2014-06-03 12:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-03 12:36:50 UTC
pm-rhel: needinfo? (redhatbugs)


Attachments (Terms of Use)

Description Zenon Panoussis 2007-04-13 12:04:30 UTC
Description of problem:

(rpmbuild --rebuild kdebase-3.5.4-13.5.el5.src.rpm
 ksysguard.cc:55:33: error: dnssd/remoteservice.h: No such file or directory
 => missing "buildrequires: kdnssd-avahi-devel" in kdebase.)

rpmbuild --rebuild kdnssd-avahi-0.1.3-0.1.20060713svn.fc6.src.rpm
remoteservice.h:25:31: error: dnssd/servicebase.h: No such file or directory
=> kdnssd-avahi buildrequires itself. 

Having to bootstrap the build tools in order to build them is perfectly normal,
but having to bootstrap packages at this high level shouldn't be necessary.
servicebase.h and the other header files are all in the tarball, so the build
process should look for them in the buildroot, not in the system includedir.

Comment 1 RHEL Product and Program Management 2014-03-07 12:42:18 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-03 12:36:50 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.