Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236327 - Traceback when trying to save dual head configuration
Summary: Traceback when trying to save dual head configuration
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard: bzcl34nup
: 213027 238717 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 07:29 UTC by Uwe Kubosch
Modified: 2008-08-02 23:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-11 18:52:56 UTC


Attachments (Terms of Use)
patch for /usr/share/system-config-display/xConfigDialog.py (deleted)
2007-05-14 16:30 UTC, Will Woods
no flags Details | Diff

Description Uwe Kubosch 2007-04-13 07:29:35 UTC
Description of problem:
I have a Dell Precision M90 laptop with nvidia Quadro FX 2500M graphics chips. 
nvidia-x11-drv graphics drivers are installed.

Trying to save a dual head setup for this driver results in a python traceback.

Version-Release number of selected component (if applicable):
1.0.51-1.fc7

How reproducible:
Happens every time.  The same error is present in FC6.

Steps to Reproduce:
1. Connect 2 LCD monitors 1600x1200
2. Select 1600x1200 resolution for first monitor.
3. Select nvidia driver in Hardware -> Video Card
4. Check "Dual Head" checkbox
5. Select Generic LCD monitor 1600x1200 for second monitor
6. Click "OK" button

  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 137, in ok
    lower_vrefresh, upper_vrefresh =
string.split(str(self.second_monitor_vrefresh), "-")
ValueError: need more than 1 value to unpack


Expected results:
No traceback, and nnew /etc/X11/xorg.conf file saved with dual head setup.

Additional info:
Thank you for your good work!

Comment 1 Adam Jackson 2007-05-03 18:41:09 UTC
*** Bug 238717 has been marked as a duplicate of this bug. ***

Comment 2 Will Woods 2007-05-14 16:30:36 UTC
Created attachment 154666 [details]
patch for /usr/share/system-config-display/xConfigDialog.py

This patch fixes dual-head configuration for LCDs - sometimes the sync ranges
are a single number ('60.0') instead of a range ('60.0-60.0'), so you need to
handle them accordingly.

Comment 3 Bug Zapper 2008-04-04 00:03:59 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Adam Jackson 2008-04-11 18:52:56 UTC
Fixed in git, will push to rawhide shortly.

Comment 5 Adam Jackson 2008-04-11 18:53:58 UTC
*** Bug 213027 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.