Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236311 - coreutils shows good links as dangling
Summary: coreutils shows good links as dangling
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 00:08 UTC by Sammy
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 5.97-12.5.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 08:24:09 UTC


Attachments (Terms of Use)
Color definitions file (deleted)
2007-04-13 13:35 UTC, Sammy
no flags Details

Description Sammy 2007-04-13 00:08:45 UTC
Description of problem:

After updating to coreutils 5.97-12.4.fc6 good symlinks show as dangling.
I am using "ls -bCAF --color". Downgrading to 12.3 does not have this
problem.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2007-04-13 11:48:25 UTC
I can't reproduce this.  Please give a test case.

Comment 2 Sammy 2007-04-13 13:35:41 UTC
Created attachment 152541 [details]
Color definitions file

Comment 3 Sammy 2007-04-13 13:36:53 UTC
I have investigated this further and found the following:

In /etc/DIR_COLORS and /etc/DIR_COLORS.xterm I have set:

          ORPHAN 01;05;37;41  # orphaned syminks

where 05=blink and others colors. This shows the orphaned syminks as
blinking bold white on red backgorund. Otherwise regular symlinks show
as cyan.

With the latest upgrade and using "ls --color" all symlinks are blinking BUT
if I comment this line in DIRCOLORS then the orphaned symlinks show as cyan
(no different than non orphaned) except when you do ls -l, in which case
only the link target itself shows as blinking, which is correct because I set
missing files to blink as well. I am going to attach my DIR_COLORS.

Comment 4 Tim Waugh 2007-04-17 11:51:12 UTC
Test case:

rm -rf arena
mkdir arena
cd arena
touch file
ln -s file symlink
/bin/ls --color | cat -vet

Actual result:
^[[00m^[[00mfile^[[00m$
^[[01;05;37;41msymlink^[[00m$

Expected result:
^[[00m^[[00mfile^[[00m$
^[[00;36msymlink^[[00m$

Should be fixed in coreutils-5.97-12.5.fc6, shortly to appear in
updates-testing.  Thanks for catching this.

Comment 5 Fedora Update System 2007-04-18 22:37:48 UTC
Fixed in update: coreutils-5.97-12.5.fc6


Note You need to log in before you can comment on or make changes to this bug.