Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236281 - rpm --verify errors on /etc/cups and /var/spool/cups/tmp
Summary: rpm --verify errors on /etc/cups and /var/spool/cups/tmp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-12 20:15 UTC by John W. Lockhart
Modified: 2008-01-10 12:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-10 12:38:19 UTC


Attachments (Terms of Use)

Description John W. Lockhart 2007-04-12 20:15:56 UTC
Description of problem:
rpm --verify fails because modes on 2 directories on the file system
after installation do not match the settings in the spec file.

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.9.11 and
cups-1.1.22-0.rc1.9.20


How reproducible:

rpm -e --allmatches --nodeps cups
rm -rf /etc/cups /var/spool/cups
rpm -ivh cups
rpm -V cups

  
Actual results:
root@amd64-4as tps]# rpm -V cups
.M.......   /etc/cups
.M.......   /var/spool/cups/tmp

.qa.[root@amd64-4as tps]# ls -ld /var/spool/cups/tmp /etc/cups
drwxrwxr-x  5 root sys 4096 Apr 12 16:04 /etc/cups
drwxrwx--T  2 root sys 4096 Apr 12 12:53 /var/spool/cups/tmp
.qa.[root@amd64-4as tps]# rpm -qvl cups | egrep '(/etc/cups|/var/spool/cups/tmp)$'
drwxr-xr-x    2 root    sys                 0 Apr 12 12:53 /etc/cups
drwx-----T    2 root    sys                 0 Apr 12 12:53 /var/spool/cups/tmp


Expected results:
clean verify without errors

Additional info:

Comment 1 Tim Waugh 2008-01-10 12:38:19 UTC
Fixed in Fedora.


Note You need to log in before you can comment on or make changes to this bug.