Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236277 - direct I/O locking confused dlm
Summary: direct I/O locking confused dlm
Keywords:
Status: CLOSED DUPLICATE of bug 234086
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Teigland
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-12 20:07 UTC by Nate Straz
Modified: 2009-09-03 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 13:50:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nate Straz 2007-04-12 20:07:13 UTC
Description of problem:

We were running a simultaneous streaming direct I/O test case on two nodes, kool
and salem.  The dd ran on salem, but kool didn't make any progress.  After
killing the dd on salem, the dd on kool remained stuck.  Here is the relevant
output from debugfs.

Kool (node 4):
Resource ffff81005faec0c0 Name (len=24) "       2             40a"  
Local Copy, Master is node 5
Granted Queue
Conversion Queue
01550021 PR (CW) Master:     02dc0022
Waiting Queue


Salem (node 5):
Resource ffff81006628ac80 Name (len=24) "       2             40a"  
Master Copy
Granted Queue
02960031 CW
Conversion Queue
02dc0022 NL (CW) Remote:   4 01550021
Waiting Queue

Test case:
1. create file which is 1/2 of memory.

dd if=/dev/urandom bs=1024k count=1024 of=largefile

2. on both nodes, read the file until the I/O speed stabalizes.

for i in `seq 10`; do dd if=largefile of=/dev/null bs=4k; done

3. on both nodes, read the file with direct I/O
for i in `seq 10`; do dd if=largefile of=/dev/null bs=4k iflag=direct; done


Version-Release number of selected component (if applicable):
2.6.21-rc6 + gfs from CVS HEAD

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Teigland 2007-04-19 13:50:10 UTC

*** This bug has been marked as a duplicate of 234086 ***


Note You need to log in before you can comment on or make changes to this bug.