Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236204 - rgmanager restarts system when trying to stop it just after it's start
Summary: rgmanager restarts system when trying to stop it just after it's start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-12 14:29 UTC by Andrey Mirkin
Modified: 2009-04-16 22:37 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0580
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:46:01 UTC


Attachments (Terms of Use)
This patch fixes the problem (deleted)
2007-04-12 14:29 UTC, Andrey Mirkin
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0580 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2007-10-30 15:37:24 UTC

Description Andrey Mirkin 2007-04-12 14:29:13 UTC
Description of problem:
When trying to stop rgmanager just after it was started rgmanager write to log:
clurgmgrd[8751]: <crit> Watchdog: Daemon died, rebooting...

And after that rgmanger reboot the node.


Version-Release number of selected component (if applicable):
rgmanager-2.0.23-1


How reproducible:
Do "/etc/init.d/rgmanager restart" in cycle

Actual results:
Node is rebooted.

Expected results:
Restarted rgmanager

Additional info:
The problem is that signal handlers are set not right after watchdog is started.
So when we are sending TERM signal to main process, it will exit and watchdog
will get exit status.

Comment 1 Andrey Mirkin 2007-04-12 14:29:14 UTC
Created attachment 152452 [details]
This patch fixes the problem

Comment 2 Lon Hohberger 2007-04-12 17:26:20 UTC
Patch applied to RHEL5 and CVS head.

Comment 4 Kiersten (Kerri) Anderson 2007-04-23 17:25:36 UTC
Fixing Product Name.  Cluster Suite was integrated into the Enterprise Linux for
version 5.0.

Comment 7 errata-xmlrpc 2007-11-07 16:46:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html



Note You need to log in before you can comment on or make changes to this bug.