Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236135 - RPCbind conflicts with glibc
Summary: RPCbind conflicts with glibc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
: 236708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-12 01:37 UTC by Marc Wiriadisastra
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-20 14:29:22 UTC


Attachments (Terms of Use)

Description Marc Wiriadisastra 2007-04-12 01:37:28 UTC
Description of problem:
Doing an update in FC6 test 3 the latest test I tried to do an update with all
the new packages and the following error gets spit out.

[('file /usr/sbin/rpcinfo from install of rpcbind-0.1.4-3.fc7 conflicts with
file from package glibc-common-2.5.90-19', (7, '/usr/sbin/rpcinfo', 0L))]

How reproducible:

It happens every time I try to update.

Steps to Reproduce:
1. yum -y update
  
Actual results:

[('file /usr/sbin/rpcinfo from install of rpcbind-0.1.4-3.fc7 conflicts with
file from package glibc-common-2.5.90-19', (7, '/usr/sbin/rpcinfo', 0L))]

Expected results:

It should update rpcbind

Additional info:

It's run in vmware but I don't believe that should make an issue since it is a
package related issue.

Comment 1 Matthew Miller 2007-04-12 12:58:26 UTC
Although it's far from obvious, all Fedora 7 test bugs should be filed against
"devel", not "test#". Moving this, so it doesn't get lost.

This has been a bulk message. We return you now to your regularly scheduled
program, already in progress.

Comment 2 Steve Dickson 2007-04-17 13:14:26 UTC
Are you running Rawhide or FC6? It sounds like
the repos your using are pointed to Rawhide
instead of FC6...

Note: I'm running a number of FC6 machines,
doing yum updates daily, and I'm not seeing
this problem

Comment 3 Marc Wiriadisastra 2007-04-17 13:18:15 UTC
I'm running rawhide.

Comment 4 Valent Turkovic 2007-04-17 13:35:49 UTC
I have a Fedora7 test3 setup and I get this error also. I filed a duplicated bug
report.

Comment 5 Marc Wiriadisastra 2007-04-17 13:43:14 UTC
Yeah I have Fedora 7 Test 3 but I've been told to call it rawhide.  Not sure if
that makes a difference or not.

Comment 6 Steve Dickson 2007-04-17 20:22:04 UTC
Well because the rpcbind rpm now supplies the rpcinfo
command and its man page, they had to be removed
from the glibc-common and man-pages (respectively) 
rpms otherwise there would be a confliction...

So I need to added a Requires: clause to
ensure the correct rpms are installed. 

The needed rpms are:
glibc-common-2.5.90-20
man-pages-2.43-12

So please try 'yum update glibc-common man-pages rpcbind'
which should fix things up.


Comment 7 Jeremy Katz 2007-04-19 20:48:25 UTC
*** Bug 236708 has been marked as a duplicate of this bug. ***

Comment 8 Valent Turkovic 2007-04-19 21:10:25 UTC
I tried normal 'yum update' on Fedora 7 test 3 - and it passes update without
conflict. For me this is a squashed bug :)
Good work guys.
Thank you.

Comment 9 Marc Wiriadisastra 2007-04-20 00:16:57 UTC
Yep it works fine for me as well.


Note You need to log in before you can comment on or make changes to this bug.