Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236117 - X won't start when using vesa driver
Summary: X won't start when using vesa driver
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 23:47 UTC by Steven Usdansky
Modified: 2018-04-11 07:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-18 16:14:54 UTC


Attachments (Terms of Use)
xorg.conf and Xorg.0.log (deleted)
2007-04-11 23:47 UTC, Steven Usdansky
no flags Details
Xorg log file from running X with no xorg.conf (deleted)
2007-04-12 19:09 UTC, Steven Usdansky
no flags Details

Description Steven Usdansky 2007-04-11 23:47:03 UTC
Description of problem:
X won't start when using the vesa driver; I need to use the fbdev driver. The
vesa driver worked fine in FC6.

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-1.3.0-5.fc7.i386

How reproducible:
Always

Steps to Reproduce:
1. configure /etc/X11/xorg.conf to use vesa driver
2. startx
3.
  
Actual results:
X does not start

Expected results:
X starts normally

Additional info:
attached file contains copies of
  1. /etc/X11/xorg.conf
  2. /var/log/Xorg.).log

Comment 1 Steven Usdansky 2007-04-11 23:47:03 UTC
Created attachment 152330 [details]
xorg.conf and Xorg.0.log

Comment 2 Matěj Cepl 2007-04-12 14:20:14 UTC
Steven, could you try to restart Xorg without any /etc/X11/xorg.conf whatsoever?
What happens? COuld you attach /var/log/Xorg.*.log from this excercise, please?

Comment 3 Steven Usdansky 2007-04-12 19:09:24 UTC
Created attachment 152500 [details]
Xorg log file from running X with no xorg.conf

the via driver has never worked for me; I've always used the vesa driver

Comment 4 Adam Jackson 2007-05-26 18:06:50 UTC
Do you happen to have an X log from using the vesa driver in FC6?

The log file for running with the vesa driver shows no modes coming back from
the BIOS; I'm curious to know why that would have worked in FC6 but not now.

Comment 5 Adam Jackson 2008-02-18 16:14:54 UTC
No word in nine months, closing.

I suspect this is due to x86emu triggering different behaviour than vm86 though.


Note You need to log in before you can comment on or make changes to this bug.