Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236073 - autoconf 2.61 requires m4 >= 1.4.7
Summary: autoconf 2.61 requires m4 >= 1.4.7
Alias: None
Product: Fedora
Classification: Fedora
Component: autoconf
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-11 19:54 UTC by Ville Skyttä
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-10-29 17:39:19 UTC

Attachments (Terms of Use)

Description Ville Skyttä 2007-04-11 19:54:26 UTC
I needed autoconf 2.61 on FC-6 for something, and updated it from Rawhide
locally.  However, that resulted in a broken setup without rpm notifying me
about it, as autoconf 2.61 appears to require m4 version 1.4.7 or later due to
its use of "m4 --debugfile".

So the dependency on m4 in autoconf should be made versioned like "Requires: m4
>= 1.4.7".  Don't know whether the BuildRequires on m4 should be versioned or not.

See also bug 230601 and

Comment 1 Ville Skyttä 2007-04-11 19:55:20 UTC
Oops, how did that severity end up as "urgent"?  Fixed.

Comment 2 Stepan Kasal 2007-10-29 17:39:19 UTC
Resolved in autoconf-2.61-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.