Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236070 - gnome-screensaver doesn't work with thinkfinger
Summary: gnome-screensaver doesn't work with thinkfinger
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screensaver
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 19:40 UTC by Bryan O'Sullivan
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 21:52:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 411293 None None None Never

Description Bryan O'Sullivan 2007-04-11 19:40:47 UTC
Description of problem:

I'm using thinkfinger from Extras, and while almost everything (sudo, login,
gdm, etc) is happy to accept a fingerprint swipe instead of a password,
gnome-screensaver insists on just a password.

Version-Release number of selected component (if applicable):

gnome-screensaver-2.18.0-6.fc7
thinkfinger-0.2.2-4.fc7

How reproducible:

100%

Steps to Reproduce:
1. Install thinkfinger.
2. Edit /etc/pam.d/system-auth to add a thinkfinger line as the second entry
   in the auth block:
   auth sufficient pam_thinkfinger.so
  
Actual results:

Everything I've tried except for gnome-screensaver accepts a finger swipe.

Comment 1 Bryan O'Sullivan 2007-04-11 19:41:42 UTC
I'm filing this against gnome-screensaver because googling suggests that
gnome-screensaver is at fault, not thinkfinger.

Comment 2 Ray Strode [halfline] 2007-04-11 21:52:59 UTC
Actually it is thinkfinger's bug.  PAM modules shouldn't expect to be run with
root privileges.  Jon (the author of gnome-screensaver) wrote some patches to
make thinkfinger work better, though. Have a look at:

http://thread.gmane.org/gmane.linux.drivers.thinkfinger/327
http://thread.gmane.org/gmane.linux.drivers.thinkfinger/328

There is an upstream gnome report here with more information here:
http://bugzilla.gnome.org/show_bug.cgi?id=411293

Anyway, closing since it's a thinkfinger problem that should get fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.