Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236029 - checkmodule manpage is incorrect
Summary: checkmodule manpage is incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: checkpolicy
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Josef Kubin
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 15:56 UTC by Linda Knippers
Modified: 2013-04-12 19:06 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-1072
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-05 13:59:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:1072 normal SHIPPED_LIVE checkpolicy bug fix update 2007-12-05 13:59:14 UTC

Description Linda Knippers 2007-04-11 15:56:00 UTC
Description of problem:
The manpage for checkmodule describes a -d (debug) option that is
not actually implemented.  

Version-Release number of selected component (if applicable):
checkpolicy-1.33.1-2.el5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
checkmodule -d gives a usage message

Expected results:
Should either work or not be in the manpage.  

Additional info:
The -d option on checkpolicy does work.  It looks like checkmodule
was intended to do the same at some point (getopt arguments include
a -d option) but was never implemented or was removed.

Comment 1 RHEL Product and Program Management 2007-06-05 20:32:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 4 Daniel Walsh 2007-07-10 18:53:15 UTC
Fixed in checkpolicy-1.33.1-3

Comment 6 Josef Kubin 2007-11-15 22:02:17 UTC
Fixed in checkpolicy-1.33.1-4

Comment 10 errata-xmlrpc 2007-12-05 13:59:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1072.html



Note You need to log in before you can comment on or make changes to this bug.