Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236028 - Software Update Crash
Summary: Software Update Crash
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 15:49 UTC by Adam C
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 16:35:45 UTC


Attachments (Terms of Use)

Description Adam C 2007-04-11 15:49:43 UTC
Description of problem:

Component: Software Manager
Summary: TB9f78d0ec main.py:244:execute:DatabaseError: database disk image is
malformed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 390, in ?
    main()
  File "/usr/sbin/pirut", line 386, in main
    pm.run()
  File "/usr/sbin/pirut", line 299, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 310, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 154, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 291, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 289, in populateSack
    dobj = repo.cacheHandler.getPrimary(xml, csum)
  File "/usr/lib/python2.4/site-packages/yum/sqlitecache.py", line 96, in getPrimary
    return self._getbase(location, checksum, 'primary')
  File "/usr/lib/python2.4/site-packages/yum/sqlitecache.py", line 89, in _getbase
    self.updateSqliteCache(db, parser, checksum, metadatatype)
  File "/usr/lib/python2.4/site-packages/yum/sqlitecache.py", line 373, in
updateSqliteCache
    cur.execute("DELETE FROM "+table+ " where pkgKey in %s" % delpkgs)
  File "/usr/lib/python2.4/site-packages/sqlite/main.py", line 244, in execute
    self.rs = self.con.db.execute(SQL)
DatabaseError: database disk image is malformed

Local variables in innermost frame:
self: <sqlite.main.Cursor instance at 0xb5b483ac>
parms: ()
SQL: DELETE FROM requires where pkgKey in ()


Version-Release number of selected component (if applicable):


How reproducible:
Every time I run Software Update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-04-16 14:55:00 UTC
This looks like you've somehow managed to get a corrupt sqlite cache.

Does it work if you run 'yum clean dbcache' first?

Comment 2 Adam C 2007-04-17 15:48:16 UTC
Yes it does.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.