Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 236009 - yum erased gtkhtml38 whn updating gtkhtml3
Summary: yum erased gtkhtml38 whn updating gtkhtml3
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml38
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 236518 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 14:12 UTC by eric
Modified: 2014-03-17 03:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 20:44:35 UTC


Attachments (Terms of Use)

Description eric 2007-04-11 14:12:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10

Description of problem:
> i noticed my gnucash would not run after today's yum update.
 > i ran gnucash from the terminal and it complained:
 > --
 > gnucash-bin: error while loading shared libraries: libgtkhtml-3.8.so.15:
 > cannot open shared object file: No such file or directory
 > --
 > so i checked the yum.log:
 > --
 > ...
 > Apr 10 19:08:29 Updated: gtkhtml3.i386 3.14.1-1.fc7
 > Apr 10 19:12:23 Erased: gtkhtml38
 > ...
 > --
 > i reinstalled gtkhtml38 and gnucash works again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1. install gnucash
2. yum update

Actual Results:
yum.log:
Erased: gtkhtml38

Expected Results:
should not have been erased

Additional info:

Comment 2 Michael Schwendt 2007-04-11 14:53:42 UTC
And the -devel package contains an even wronger Provides.


Comment 3 Bill Nottingham 2007-04-11 19:44:25 UTC
So, how are build requirements on the ABI provided by the package supposed to
work? What's the point if the requiring package has to specify that it exactly
requires gtkhtml38?

Comment 4 Bill Nottingham 2007-04-11 20:44:35 UTC
-4 building. Bleah.

Comment 5 Jeremy Katz 2007-04-25 16:42:46 UTC
*** Bug 236518 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.