Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235997 - Opera no longer starts since currently updates
Summary: Opera no longer starts since currently updates
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.5.0-gcj
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 12:43 UTC by Hervé Riboulot
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-12 15:57:19 UTC


Attachments (Terms of Use)

Description Hervé Riboulot 2007-04-11 12:43:38 UTC
Description of problem:

Opera, which was working well (rpm), does no longer start, since updates (April
10th).

Messages are:

ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
Erreur de segmentation
(segmentation fault)

rpm -qf /usr/lib/gcj-4.1.2/libjvm.so 
libgcj-4.1.2-8

Libawt.so is provided by Sun Java, implemented by a manual method (using *.bin):
/opt/jre1.5.0_11/lib/i386/libawt.so

alternatives is properly set up.

rpm -q opera
opera-9.10-20061214.6


Version-Release number of selected component (if applicable):

rpm -qf /usr/lib/gcj-4.1.2/libjvm.so 
libgcj-4.1.2-8

Libawt.so is provided by Sun Java, implemented by a manual method (using *.bin):
/opt/jre1.5.0_11/lib/i386/libawt.so

alternatives is properly set up.

rpm -q opera
opera-9.10-20061214.6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Hervé Riboulot 2007-04-11 13:56:45 UTC
Workaround: to upgrade the Opera version to 9.20.

 rpm -q opera
opera-9.20-20070409.6




Comment 2 Thomas Fitzsimmons 2007-04-12 15:58:30 UTC
I can't fix bugs relating to Sun Java 1.5.0 nor Opera because I don't have the
source code for those packages.



Note You need to log in before you can comment on or make changes to this bug.