Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235990 - Broadcom network card fails on Fedora 7 test 3 (b44)
Summary: Broadcom network card fails on Fedora 7 test 3 (b44)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 10:25 UTC by Valent Turkovic
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-25 18:53:13 UTC


Attachments (Terms of Use)
dmesg output (deleted)
2007-04-17 07:35 UTC, Valent Turkovic
no flags Details
modprobe.conf (deleted)
2007-04-17 07:38 UTC, Valent Turkovic
no flags Details

Description Valent Turkovic 2007-04-11 10:25:21 UTC
Description of problem:
I install Fedora 7 test 3 and run 'ifconfig' and no eth0 device exists!
I have a broadcom network card using b44 module.
I remove and reload b44 module - than eth0 device exists for a minute or two and
I can use it - browse the net and get updates.
After no more than 2 minutes eth0 device dissapears and I can't use it anymore.
I have tested this on default kernel and also the last one that is available
today. On both kernels I see the same behavior.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.


Steps to Reproduce:
1. Install Fedora 7 test 3
2. Try to use the network card
3.
  
Actual results:


Expected results:
Working network.

Additional info:

Comment 1 John W. Linville 2007-04-13 19:53:48 UTC
Could you attach the output of running 'dmesg' and also 'lspci'?  Thanks!

Comment 2 Valent Turkovic 2007-04-17 07:32:37 UTC
Ok, I found out something else.

It seams that there is a bug somewhere but not the one I described in the first
post. Sorry for that.

The problem was that now my broadcom network card, lspci:
02:0e.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
is eth1 and not etho anymore!

This probably happened after first kernel upgrade, because after the install it
was eth0.

I deleted all network scripts in:
/etc/sysconfig/network-scripts/
and created new ones.

But I still have problems, after the boot I don't have working network. I remove
and reload b44 kernel module and network work from then on.

Now I have 2.6.20-1.3059.fc7 kernel.



Comment 3 Valent Turkovic 2007-04-17 07:35:04 UTC
Created attachment 152775 [details]
dmesg output

dmesg output

Comment 4 Valent Turkovic 2007-04-17 07:38:16 UTC
Created attachment 152776 [details]
modprobe.conf

modprobe config file

Comment 5 Valent Turkovic 2007-04-17 07:40:14 UTC
any ideas?

Comment 6 John W. Linville 2007-04-17 15:01:19 UTC
Your modprobe.conf file has "alias eth1 b44" and has "#alias eth0 b44" (i.e. 
the eth0 version is commented out).  Is this a change you made intentionally?

Comment 7 Valent Turkovic 2007-04-17 17:32:00 UTC
Yes I added comment for eth0.

The default version was with both "alias eth1 b44" and also "alias eth0 b44" I
didn't look at the modprobe.conf before this issue so I don't know if before
kernel upgrade there were both eth0 and eth1 tied with b44.

I hoped that atleast eth1 would work fine if I comment eth0 but that didn't help.
I'll try not to delete again all networking scripts and leave only eth0 alias in
modprobe.conf

be back after the reboot.

Comment 8 Valent Turkovic 2007-04-18 08:31:13 UTC
I updated to another kernel - 2.6.20-1.3079.fc7

THis is not a kernel bug. Because everything works fine now. My card is eth0 and
works after the reboot with no problem.

Maybe it is a system-config-network bug?

This is a snow-stopper for new linux users so should be escalated to a high
level - and fixed swiftly.

Comment 9 Dave Jones 2007-04-23 16:02:30 UTC
the eth0/eth1 switching was caused by an anaconda bug which should now be fixed.

do a reinstall when test4 comes out, it should be fixed.
(or you could try a rawhide install before then).

Comment 10 Valent Turkovic 2007-04-27 13:51:50 UTC
Ok, I will. thanks.


Note You need to log in before you can comment on or make changes to this bug.