Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235949 - After upgrade to kernel-2.6.20-1.2933.fc6.i686 can't connect eth0 anymore
Summary: After upgrade to kernel-2.6.20-1.2933.fc6.i686 can't connect eth0 anymore
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 23:21 UTC by Leobardo Terpán
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 14:44:40 UTC


Attachments (Terms of Use)

Description Leobardo Terpán 2007-04-10 23:21:45 UTC
Description of problem:
I've been running fc6 on kernel-2.6.19-1.2911.6.5.fc6, yesterday I made an 
upgrade to kernel-2.6.20-1.2933.fc6 by means of yum-updatesd, After update I
wasn't able to connect to internet, apparently eth0 is unable to connect because
my ip is already occupied by other host. 

Network can be manually activated by means of system-config-network:

[root@lterpan etc]# /etc/init.d/network stop
Interrupción de la interfaz eth0:                          [  OK  ]
Interrupción de la interfaz de loopback:                   [  OK  ]
SIOCGIFFLAGS: No such device
[root@lterpan etc]# /etc/init.d/network start
Activación de la interfaz de loopback:                     [  OK  ]
Activando interfaz eth0:  sysfs class device: Permission denied
Error, algún otro host ya usa la dirección 192.168.X.XX.
                                                           [FALLÓ]
[root@lterpan etc]# ping 192.168.X.XX
connect: La red es inaccesible
[root@lterpan etc]# system-config-network
[root@lterpan etc]# ping 192.168.X.XX
PING 192.168.2.45 (192.168.X.XX) 56(84) bytes of data.
64 bytes from 192.168.2.45: icmp_seq=1 ttl=255 time=0.913 ms
64 bytes from 192.168.2.45: icmp_seq=2 ttl=255 time=0.225 ms

--- 192.168.X.X ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.225/0.569/0.913/0.344 ms


Version-Release number of selected component (if applicable):

kernel-2.6.20-1.2933.fc6.i686

This problem is also described elsewhere (see
http://www.unixboard.de/vb3/showthread.php?t=28733)

How reproducible:

I would appreciate your help

Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chuck Ebbert 2007-04-11 14:44:40 UTC
This is an selinux bug, fixed by the latest update in updates-testing.


Note You need to log in before you can comment on or make changes to this bug.