Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235947 - Good: libode.a is required to build a new rpm
Summary: Good: libode.a is required to build a new rpm
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ode
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 22:53 UTC by Benoît Marcelin
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 07:16:13 UTC


Attachments (Terms of Use)

Description Benoît Marcelin 2007-04-10 22:53:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr-FR; rv:1.8.1.3) Gecko/20070320 Firefox/2.0.0.3

Description of problem:
I want to build a package, the build need libode.a (who are deleted in the spec of ode)

Version-Release number of selected component (if applicable):
0.7-2

How reproducible:
Always


Steps to Reproduce:
1.rpmbuild -ba rpmbuild/SPEC/.....spec
2.
3.

Actual Results:


Expected Results:


Additional info:

Comment 1 Christian Iseli 2007-04-11 06:45:10 UTC
Two questions:
1. why did you add me to the CC of this bug ?
2. what makes you think you absolutely need the static library ?


Comment 2 Hans de Goede 2007-04-11 07:16:13 UTC
We (Fedora) try to avoid static libs as much as possible. We do this up to the
point of not even shipping them, this is a feature not a bug.

Simply replace /usr/lib/libode.a with -lode in the Makefile should do the trick.

Also next time please provide some usefull information, like a link to the SRPM
for the package you are trying to build, IOW exact reproduction instructions for
you're problem. Maybe then I could have been of more help, but with the very
small amount of info currently provided I can only say this is not a bug, and
advice you to use -lode instead of trying to hardcode a path to libode.a in the
makefile.

Closing ...


Comment 3 Benoît Marcelin 2007-04-11 11:29:39 UTC
To answer to Christian Iseli :
1 - because you are the latest packager of ode (on the changelog)
2 - during the %build of the rpm he what's two no-existing static library
(libode.a and an other) to make an object : gcc: /usr/lib64/libode.a: No such
file or directory

So I will try to do than Hans de Goede tell me

Sorry for the inconvenience and my poor english.


Note You need to log in before you can comment on or make changes to this bug.