Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235928 - xemacs tabify/untabify not working
Summary: xemacs tabify/untabify not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 20:40 UTC by Tim Taiwanese Liim
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 15:07:08 UTC


Attachments (Terms of Use)

Description Tim Taiwanese Liim 2007-04-10 20:40:43 UTC
Description of problem:
    The tabify/untabify command disappears in FC6.  It was available 
    in FC5 (xemacs 21.4 (patch 19)).

Version-Release number of selected component (if applicable):
    xemacs-packages-base-20060510-3.fc6
    xemacs-21.5.27-8.fc6
    xemacs-common-21.5.27-8.fc6
    XEmacs 21.5  (beta27) "fiddleheads" (linux, Mule) of Thu Jan 25 2007 on hammer2
    [version 21.5.27 of May 2006]

How reproducible:
    always

Steps to Reproduce:
    1. start xemacs
    2. M-x tabify
  
Actual results:
    - tabify unrecognized.  Same for untabify.

Expected results:
    - command tabify should be available.

Additional info:

Comment 1 Tim Taiwanese Liim 2007-04-11 02:53:42 UTC
Some other commands that are missing since FC5:
    display-time
    vc-load-vc-hooks
Maybe they are missing for a good reason that I don't understand.

Comment 2 Jens Petersen 2007-04-11 03:20:50 UTC
I suspect you're missing some xemacs-sumo packages since they're not
all installed by default any more.

Comment 3 Ville Skyttä 2007-04-11 15:07:08 UTC
Right, install the xemacs-packages-extra package.  It's regrettable that during
the FC5->FC6 upgrade, xemacs-packages-extra was not pulled in for people who had
xemacs-sumo installed.

Comment 4 Tim Taiwanese Liim 2007-04-11 15:28:54 UTC
Thanks!  Yes xemacs-packages-extra solved the issue.  Yes it's
rather hard for users to guess which xemacs-related rpms to pull in.



Note You need to log in before you can comment on or make changes to this bug.