Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235909 - libnl headers have error on i386
Summary: libnl headers have error on i386
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libnl
Version: rawhide
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL: http://buildsys.fedoraproject.org/log...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 18:51 UTC by Dennis Gilmore
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-29 15:01:25 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2007-04-10 18:51:49 UTC
Description of problem:
Trying to build knetworkmanager update for Fedora and build fails as the 
headers are incorrect 
/usr/include/netlink/rtnetlink-kernel.h:498: error: '__u64' does not name a 
type

build was fine on x86_64 so it seems to be some 32bit  issue

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
build fails

Expected results:
build to succeed 

Additional info:

Comment 1 Neil Horman 2007-04-10 20:18:02 UTC
This strikes me as more of a knetworkmanager issue.  knetworkmanager should not
include rtnetlink-kernel.h directly, but rather netlink.h, which includes
linux/types.h -> asm/types.h, where __u64  is definately defined.  It may be
that knetworkmanager is defining  __STRICT_ANSI__ during its build, which would
cause its lack of definition, but I don't think kde utils define that nominally.
 Likewise, if you were using a compiler other than gcc, __GNUC__ wouldn't be
defined, and you wouldn't get __u64 defined.  Either way, figure out which of
those macros is or isn't defined properly, fix that up, and your problem should
go away. 

Comment 2 Neil Horman 2007-08-29 14:52:51 UTC
ping.  Any update?

Comment 3 Dennis Gilmore 2007-08-29 15:01:25 UTC
sorry forgot about this bug.  I fixed it.  i had to pass an additional switch 
to knetworkmanager which fixed it.

Thanks for the reminder.


Note You need to log in before you can comment on or make changes to this bug.