Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235892 - Yum miscaculates disk space requirements
Summary: Yum miscaculates disk space requirements
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
: 233391 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 17:32 UTC by Kwan Lowe
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-28 05:37:38 UTC


Attachments (Terms of Use)
Full output of yum update session (deleted)
2007-04-10 17:32 UTC, Kwan Lowe
no flags Details

Description Kwan Lowe 2007-04-10 17:32:19 UTC
Previous bug 233391 against test:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233391



Description of problem:
yum miscalculates disk requirements when disk space is low:
[snip]
Transaction Summary
=============================================================================
Install      0 Package(s)
Update      52 Package(s)
Remove       0 Package(s)

Total download size: 76 M
[snip]

Error Summary
-------------
Disk Requirements:
  At least 5732MB needed on the /usr filesystem.

[root] xm-fc7-001 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
[snip]
/dev/mapper/rootvg-usr_lv
                      1.9G  1.7G  119M  94% /usr


Version-Release number of selected component (if applicable):
yum-3.1.4-1.fc7

How reproducible:
Run "yum update" with less space than required for updates.


Steps to Reproduce:
1. Run yum update with less space than needed for proper installation

Actual results:
yum reports that Disk Requirements are close to 6Gig whereas the proper number
is about 50M extra needed.

Expected results:

yum disk space number should be correct
Additional info:

Possibly related to bug id=209980

Comment 1 Kwan Lowe 2007-04-10 17:32:19 UTC
Created attachment 152160 [details]
Full output of yum update session

Comment 2 Kwan Lowe 2007-04-10 17:34:53 UTC
*** Bug 233391 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2007-04-30 22:25:26 UTC
rpmlib disk space calculation will never be correct until #209306 is fixed.

Comment 4 Panu Matilainen 2007-08-10 11:47:38 UTC
If the miscalculation was due to #209306 then it should be fixed in current
rawhide / f8-test1 - can you verify please?

Comment 5 Panu Matilainen 2007-08-28 05:37:38 UTC
rpm 4.4.2.1 has been pushed to F7 updates which should fix or at least help
considerably. If not, feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.