Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235864 - segfault without a meaningful backtrace
Summary: segfault without a meaningful backtrace
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 236536 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 15:37 UTC by Patrice Dumas
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 2.5.90-21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-18 19:07:32 UTC


Attachments (Terms of Use)
data file that triggers the segfault (deleted)
2007-04-10 15:38 UTC, Patrice Dumas
no flags Details

Description Patrice Dumas 2007-04-10 15:37:47 UTC
Description of problem:

I get a segfault with:

plot 'bug.data' using 6:($210-$95) 

I'll attach my data file bug.data.

This is very strange.

Backtrace is:

(gdb) run
Starting program: /usr/bin/gnuplot bug-temp.plt

Program received signal SIGSEGV, Segmentation fault.
*__GI_wmemset (s=0xbf959990, c=48, n=4294964831) at wmemset.c:33
33            wp[0] = c;
(gdb) bt
#0  *__GI_wmemset (s=0xbf959990, c=48, n=4294964831) at wmemset.c:33
#1  0x00b8193b in ___printf_fp (fp=0x30, info=0x30, args=0x30)
    at printf_fp.c:1088
#2  0x00000030 in ?? ()
#3  0x00000030 in ?? ()
#4  0x00000030 in ?? ()
#5  0x00000030 in ?? ()
.......
until infinity.

I tried with FC6 gnuplot, same thing. That's a bit strange
and it may not be a gnuplot bug but an issue with my libs
or something like that. I run fedora devel.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2007-04-10 15:38:43 UTC
Created attachment 152147 [details]
data file that triggers the segfault

Comment 2 Matthew Miller 2007-04-10 16:37:03 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 3 Ivana Varekova 2007-04-13 11:29:33 UTC
There seems to be problem with gprintf(util.c) procedure - the segfault happens
when program try to write double variable (x), in format "%g" which should cause
no error. Jakub, could you please look at it.

Comment 4 Jakub Jelinek 2007-04-13 13:00:02 UTC
This is a glibc bug, reproduced with current CVS glibc built for i686, using
union { long long l; double d } u = { .l = 0x3f1a36e2eb1c432cLL };
int
main (void)
{
  __builtin_printf ("%g\n", u.d);
  return 0;
}


Comment 6 Jakub Jelinek 2007-04-16 13:00:37 UTC
*** Bug 236536 has been marked as a duplicate of this bug. ***

Comment 7 Jakub Jelinek 2007-04-18 19:07:32 UTC
Should be fixed in glibc-2.5.90-21.

Comment 8 Mephisto 2007-04-18 22:59:27 UTC
I can confirm my case to be fixed with -21 (bug 236536).

Comment 9 Patrice Dumas 2007-06-02 09:23:35 UTC
Fixed for my case too.


Note You need to log in before you can comment on or make changes to this bug.