Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235814 - DHCP in anaconda doesn't work
Summary: DHCP in anaconda doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 232512
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 11:11 UTC by Valent Turkovic
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 17:12:34 UTC


Attachments (Terms of Use)

Description Valent Turkovic 2007-04-10 11:11:48 UTC
Description of problem:
First I don't see how to select "Fedora 7 test 3" in bugzilla so I selected
"Fedora Core 6 test 3" instead.

During the install in anaconda on the package selection screen where you can
enable external repositories I click on the check box and screen appears that
says that is probing my network for an IP address. And that screen stays on
forever. I have a DHCP server running on my ADSL router and DHCP works after
Fedora 7 Test 3 install, but not during install in anaconda.

And there is no "back" button here, so system is stuck and only an poweroff or
reset helps! This is a big issue!

Version-Release number of selected component (if applicable):
Fedora 7 test 3

How reproducible:
Every time, tested 2 times.

Steps to Reproduce:
1. click on the box saying something like "get external software" during install
2. wait
3. Profit :)
  
Actual results:
System freeze, can't go back.

Expected results:
Get external repositories, install software from them.

Additional info:

Comment 1 David Cantrell 2007-04-10 15:01:25 UTC
Is this happening in the stage 1 part of the installer (the text-mode interface
asking you where your install source is?) or have you made it to the graphical
installer (anaconda)?

It sounds like you are in stage 2 and are trying to add a third party
repository, but that's just a guess.

Comment 2 Valent Turkovic 2007-04-10 20:30:11 UTC
This is happening in graphical install, I can't be sure it is 3rd or 4th screen.
In this screen:
http://images.howtoforge.com/images/the_perfect_desktop_fc6/12.jpg
I click on "add additional software repositories" and annaconda pops up a info
box saying something like "acquiering IP address for your network adapter" and
is stuck here. 
I have broadcom network adapter which uses b44 kernel module.

Comment 3 David Cantrell 2007-04-11 17:12:34 UTC

*** This bug has been marked as a duplicate of 232512 ***


Note You need to log in before you can comment on or make changes to this bug.