Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235812 - Update failure tcl-8.4.13-15.fc7.i386.rpm & tcl-8.4.13-16.fc7.i386.rpm
Summary: Update failure tcl-8.4.13-15.fc7.i386.rpm & tcl-8.4.13-16.fc7.i386.rpm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact:
URL:
Whiteboard:
: 235907 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-10 10:11 UTC by David Bentley
Modified: 2013-01-10 04:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-18 13:51:01 UTC


Attachments (Terms of Use)

Description David Bentley 2007-04-10 10:11:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070325 Firefox/2.0.0.3

Description of problem:
I noticed that this package is failing to update as of tcl-8.4.13-15.fc7.i386.rpm

Version-Release number of selected component (if applicable):
tcl-8.4.13-16.fc7.i386.rpm

How reproducible:
Always


Steps to Reproduce:
after a full update an error message is seen 
update repeated and output captured

Actual Results:
[root@bentledr-xeon ~]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package tcl.i386 1:8.4.13-16.fc7 set to be updated
Checking deps for tcl.i386 1-8.4.13-16.fc7 - u
Checking deps for tcl.i386 1-8.4.13-14.fc7 - None

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 tcl                     i386       1:8.4.13-16.fc7  development       1.8 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 1.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): tcl-8.4.13-16.fc7. 100% |=========================| 1.8 MB    00:19     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : tcl                          ######################### [1/2] 
error: unpacking of archive failed on file /usr/lib/tcl8.4: cpio: rename

Updated: tcl.i386 1:8.4.13-16.fc7
Complete!
[root@bentledr-xeon ~]# 



Expected Results:
a normal update.


Additional info:
The last update that completed OK was tcl.i386 1:8.4.13-14.fc7.i386

Comment 1 David Bentley 2007-04-10 11:30:49 UTC
Had a look to see why things are failing and it seems that the failure is as the
result of a folder called tcl8.4 existing when the updates are trying to create
a symbolic link called tcl8.4 which points at /usr/share/tcl8.4

Anyway remayved the folder named tcl8.4 and all of the wierdly named links to it
and did anoter yum update and thistime it completed without errors but the
folder now linked to as tcl8.4 in /usr/share was empty so for now I have forced
an install of tcl-8.4.13-14 (rpm -i --force) and removed tcl-8.4.13-16.fc7 (rpm -e)

Thi leaves tcl-8.4.13-14.fc7 installed with a symbolic link in /usr/lib of
tcl8.4 pointing to /usr/share/tcl8.4 which is not empty

I will check the latest package with file roller to see if the update should be
populating /usr/share/tcl8.4 before trying another update.

Comment 2 David Bentley 2007-04-10 11:52:38 UTC
The current package tcl-8.4.13-16 contains /usr/share/tcl8.4 fully populated and
now updated OK with yum.

So I am guessing that there was a change in this package between f7test3 and the
first update tcl-8.4.13-14 that cause the observed behavior.

so for now the fix to enable tcl to update is probably to just remove the folder
tcl8.4 and all the symbolic links to it from /usr/lib before going through the
process described in comment #1 before doing yum update tcl

Comment 3 David Bentley 2007-04-10 12:09:15 UTC
Just checked what was in the package from the original fc7tes3 dvd and that
package tcl-8.4.13-13 is OK so I can't explain where the folder in usr/lib named
tcl8.4 came from other than it may have been caused by a previous version of yum.

Comment 4 David Bentley 2007-04-10 12:11:13 UTC
All OK now but I will leave this open for a while for info in case anyone else
has had the same problem.

Comment 5 Marcela Mašláňová 2007-04-16 14:42:55 UTC
*** Bug 235907 has been marked as a duplicate of this bug. ***

Comment 6 Jesse Keating 2007-04-17 12:53:24 UTC
I'm reopening this.  This is really a bug in how rpm handles directories to
symlinks or vice versa, but we need to work around it in this package for now.

I'm marking it as a blocker for F7.

Comment 7 Marcela Mašláňová 2007-05-17 12:50:16 UTC
I'm reassining it as rpm problem.

Comment 8 Paul Nasrat 2007-05-17 13:17:28 UTC
This is known rpm behaviour - don't try and switch between dirs and symlinks.

Comment 9 Marcela Mašláňová 2007-05-18 13:51:01 UTC
Fix in tcl-8.4.13-17.fc7


Note You need to log in before you can comment on or make changes to this bug.