Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235760 - ip_vs_sync_state not cleared when setsockopt(IP_VS_SO_SET_STARTDAEMON) fails
Summary: ip_vs_sync_state not cleared when setsockopt(IP_VS_SO_SET_STARTDAEMON) fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 23:31 UTC by Herbert van den Bergh
Modified: 2018-10-19 22:37 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:24:45 UTC


Attachments (Terms of Use)
Fix for ipvs state modification (deleted)
2007-06-08 13:48 UTC, Neil Horman
no flags Details | Diff
new patch (deleted)
2007-06-08 13:55 UTC, Neil Horman
no flags Details | Diff
new patch (deleted)
2007-06-08 15:36 UTC, Neil Horman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Herbert van den Bergh 2007-04-09 23:31:48 UTC
Description of problem:

When setsockopt() is called with IP_VS_SO_SET_STARTDAEMON and an invalid
interface name (of a nonexistant or down interface), the sync daemon thread
fails to start, but is still reported by getsockopt() with the
IP_VS_SO_GET_DAEMON option.

Version-Release number of selected component (if applicable):
2.6.9-42.0.10

How reproducible:
All the time

Steps to Reproduce:
1. ipvsadm --start-daemon master --mcast-interface bla
2. ipvsadm -L --daemon
3. ipvsadm --stop-daemon master
  
Actual results:
output of step 2:
master sync daemon (mcast=bla, syncid=0)
output of step 3:
No daemon is running

Expected results:
<blank>

Additional info:

Comment 3 Neil Horman 2007-06-08 13:48:10 UTC
Created attachment 156574 [details]
Fix for ipvs state modification

Looks like this problem exists upstream too.  

Here's a patch to fix the problem.  I'm building it now, but if you could give
it a test and confirm that it works properly, I'd appreciate it.  Thanks!

Comment 4 Neil Horman 2007-06-08 13:55:00 UTC
Created attachment 156575 [details]
new patch

sorry, typo in the last patch.	fixed here

Comment 5 Neil Horman 2007-06-08 15:36:32 UTC
Created attachment 156585 [details]
new patch

sorry, one more typo.  Just tested this myself and it works

Comment 6 Neil Horman 2007-06-08 19:52:40 UTC
posted upstream.

Comment 7 Herbert van den Bergh 2007-06-15 01:29:12 UTC
I verified that the patch fixes the problem when applied to 2.6.9-42.0.10.


Comment 8 RHEL Product and Program Management 2007-06-19 20:24:11 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 9 Jason Baron 2007-06-29 22:31:17 UTC
committed in stream U6 build 55.15. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 11 John Poelstra 2007-08-29 00:13:18 UTC
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 12 John Poelstra 2007-09-05 22:22:19 UTC
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 13 John Poelstra 2007-09-12 00:42:06 UTC
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 15 errata-xmlrpc 2007-11-15 16:24:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.