Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235748 - 'up2date gcc' -> UnboundLocalError
Summary: 'up2date gcc' -> UnboundLocalError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Brandon Perkins
URL:
Whiteboard:
: 234091 235140 235176 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 21:58 UTC by Zack Cerza
Modified: 2007-11-17 01:14 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0815
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:34:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0815 normal SHIPPED_LIVE up2date bug fix update 2007-11-14 18:26:51 UTC

Description Zack Cerza 2007-04-09 21:58:42 UTC
Description of problem:
# up2date-nox gcc

Fetching Obsoletes list for channel: rh-x86_64-desktop-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
gcc                                     3.4.6          3.1               x86_64


Testing package set / solving RPM inter-dependencies...
An error has occurred:
exceptions.UnboundLocalError
See /var/log/up2date for more information


Version-Release number of selected component (if applicable):
up2date-4.5.5-2.el4

How reproducible:
Always

Additional info:
# tail -n28 /var/log/up2date
[Mon Apr  9 17:52:17 2007] up2date updating login info
[Mon Apr  9 17:52:17 2007] up2date logging into up2date server
[Mon Apr  9 17:52:21 2007] up2date successfully retrieved authentication token
from up2date server
[Mon Apr  9 17:52:21 2007] up2date availablePackageList from network
[Mon Apr  9 17:52:23 2007] up2date allAvailablePackageList from network
[Mon Apr  9 17:52:26 2007] up2date solving dep for: ['cpp', 'glibc-devel']
[Mon Apr  9 17:52:27 2007] up2date solving dep for: ['cpp', 'glibc',
'glibc-headers', 'glibc-headers']
[Mon Apr  9 17:52:28 2007] up2date solving dep for: ['cpp', 'glibc', 'glibc',
'kernel-headers', 'kernel-headers']
[Mon Apr  9 17:52:29 2007] up2date solving dep for: ['cpp', 'glibc', 'glibc']
[Mon Apr  9 17:52:31 2007] up2date   File "/usr/sbin/up2date-nox", line 1272, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date-nox", line 791, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date-nox", line 1127, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 82, in run
    self.__dryRun()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 204, in __dryRun
    self.percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 752, in solvedep
    ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 646, in process_deps
    changed = self.__dependencies(dependencies)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 409, in __dependencies
    if iPkg[4] == aPkg[4] or iPkg[4] == "noarch" or aPkg[4] == "noarch":

Comment 1 Red Hat Bugzilla 2007-04-12 02:20:35 UTC
User bnackash@redhat.com's account has been closed

Comment 2 Todd Sanders 2007-05-22 15:04:15 UTC
*** Bug 235176 has been marked as a duplicate of this bug. ***

Comment 3 Todd Sanders 2007-05-22 15:04:57 UTC
*** Bug 235140 has been marked as a duplicate of this bug. ***

Comment 4 Todd Sanders 2007-05-22 15:07:19 UTC
*** Bug 234091 has been marked as a duplicate of this bug. ***

Comment 5 Pradeep Kilambi 2007-07-30 15:25:13 UTC
hi Zack:

Could you gimme little more info as to when this happens. I just tried the same
and here it is:

[root@test07-64 ~]# up2date gcc

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
gcc                                     3.4.6          8                 x86_64


Testing package set / solving RPM inter-dependencies...
########################################
gcc-3.4.6-8.x86_64.rpm:     ########################## Done.                   
glibc-devel-2.3.4-2.36.x86_ ########################## Done.                   
glibc-headers-2.3.4-2.36.x8 ########################## Done.                   
glibc-kernheaders-2.4-9.1.1 ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:glibc-kernheaders      ########################################### [100%]
   2:glibc-headers          ########################################### [100%]
   3:glibc-devel            ########################################### [100%]
   4:gcc                    ########################################### [100%]
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
glibc-devel                             2.3.4          2.36                
glibc-headers                           2.3.4          2.36                
glibc-kernheaders                       2.4            9.1.100.EL          

[root@test07-64 ~]#

another scenerio I tried was upgrade and that seems to work as well.

I'm trying with the latest GA version of up2date
[root@test07-64 ~]# rpm -q up2date
up2date-4.5.5-7.el4


did you see this with fresh install of gcc or upgrade?

Could you tell me if this still happens with the latest version of up2date? if
not am I missing anything else in reproducing this.




Comment 6 Zack Cerza 2007-07-30 15:35:15 UTC
This was a fresh install of whichever version of RHEL4 Desktop had that version
of  up2date; I don't even have the machine in question anymore.

I found this bug on Desktop and have not found it on AS.

Comment 7 Pradeep Kilambi 2007-07-31 16:00:28 UTC
fixed
Committed revision 118733.

for test plan:
--------------

case-1:
------
- Kickstart a fresh rhel-4 (desktop or AS) install
- up2date <pkg>(pick a pkg which usually have deps) like gcc
- unboundlocal exception should not happen

case-2:
- install a pkg with version newer than the one on server
- up2date pkg
- no unboundlocal exception

case-3:
- setup server such that there are missing dependencies
- up2date pkg
- no unboundlocal exception.




Comment 11 errata-xmlrpc 2007-11-15 16:34:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0815.html



Note You need to log in before you can comment on or make changes to this bug.