Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235725 - In LSPP configuration /var/log/messages is SystemLow
Summary: In LSPP configuration /var/log/messages is SystemLow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: RHEL5LSPPCertTracker
TreeView+ depends on / blocked
 
Reported: 2007-04-09 19:56 UTC by Joe Nall
Modified: 2009-06-19 16:36 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:39:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0544 normal SHIPPED_LIVE selinux-policy bug fix update 2007-11-08 14:16:49 UTC

Description Joe Nall 2007-04-09 19:56:31 UTC
Description of problem: In LSPP configuration /var/log/messages is SystemLow.
Since SystemHigh data can be logged, this allows SystemHigh to SystemLow data flow.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 George C. Wilson 2007-04-09 20:56:01 UTC
sgrubb: Shouldn't all /var/log contents be at SystemHigh?

Comment 2 George C. Wilson 2007-04-09 21:00:56 UTC
Joe Nall: You're either allowing writedowns, or cannot log above SystemLow.

Linda Knippers: There is support for the log being a trusted object. Is the
issue just the level of the log file?

Chad Hanson: Would you want syslogd to run at SystemHigh as well?

Comment 3 Daniel Walsh 2007-04-10 18:11:28 UTC
Fixed in selinux-policy-2.4.6-53.el5

Comment 6 George C. Wilson 2007-04-12 00:05:52 UTC
Joe, any way you can you verify that this is fixed in the updated package?

Comment 7 George C. Wilson 2007-04-12 23:00:18 UTC
I verified this is fixed in the 55 policy.

Comment 11 errata-xmlrpc 2007-11-07 16:39:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html



Note You need to log in before you can comment on or make changes to this bug.