Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235708 - Hal mounts vfat filesystems with root ownership
Summary: Hal mounts vfat filesystems with root ownership
Keywords:
Status: CLOSED DUPLICATE of bug 234716
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-mount
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 18:56 UTC by Stewart Adam
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-12 16:42:15 UTC


Attachments (Terms of Use)

Description Stewart Adam 2007-04-09 18:56:16 UTC
Description of problem:
Not sure if this is hal or gnome-mount at fault, however when using a non-root
user, automounted drives always have root as owner and group and as a result the
drive is unwritable.

I have an ext3 filesystem with a directory owned by my regular user, and that
works fine although any vfat filesystem turns up with root/root as owner/group
with 755 permissions on all files, so the drivers are unwritable.

Version-Release number of selected component (if applicable):
gnome-mount-0.5-4.fc7
hal-0.5.9-1.fc7


How reproducible:
Always

Steps to Reproduce:
1. Mount a vfat volume
2.
3.
  
Actual results:
It's unwritable, root/root 755

Expected results:
The drives are writable (user/user 755)

Additional info:

Comment 1 Steven Op de beeck 2007-04-11 15:50:30 UTC
Hi,

My Fedora Core 7 Test3, upgraded to devel, has this problem too. I seem to
remember that this wasn't the case in the clean FC7Test3 install -- I could be
incorrect though. So I downgraden: kernel, udev (hadn't changed), gnome-mount,
hal(-libs) to the test3 version, but no change.

hal-0.5.9-0.git20070326.fc7
hal-devel-0.5.9-0.git20070326.fc7
kernel-2.6.20-1.3023.fc7
gnome-mount-0.5-3.fc7
udev-106-1.fc7

$mount
/dev/sdb1 on /media/CRUZER type vfat (rw,nosuid,nodev,uhelper=hal)

This should contain: uid=userid(or username) I believe. In Ubuntu Feisty this
looks like:
dev/sdb1 on /media/CRUZER type vfat
(rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077)

.. enabling user 1000 to write to the device.

This is the case with external-usb-disks and sticks.

I have tried disabling selinex with no effect.

Comment 2 Steven Op de beeck 2007-04-12 16:09:00 UTC
I'm posting here from the FC Test3 i386 Live cd. And I can confirm that it works
here. My vfat USBstick mounts correctly as the currently logged in user: 'fedora'.

from mount:
/dev/sdb1 on /media/CRUZER type vfat
(rw,nosuid,nodev,uhelper=hal,shortname=winnt,uid=500)

hal-0.5.9-0.git20070326.fc7
kernel-2.6.20-1.3023.fc7
gnome-mount-0.5-3.fc7
udev-106-1.fc7

Comment 3 David Zeuthen 2007-04-12 16:42:15 UTC
Btw, this is a duplicate of bug 234716

*** This bug has been marked as a duplicate of 234716 ***


Note You need to log in before you can comment on or make changes to this bug.