Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235707 - fwbackups: RFE: compress stream, not file
Summary: fwbackups: RFE: compress stream, not file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 18:54 UTC by Bernard Johnson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: fwbackups-1.43.0-0.1.rc2.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-25 21:55:34 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2007-04-09 18:54:43 UTC
Description of problem:
fwbackups compresses the end resulting backup file rather than letting tar
compress on the fly.

> # gzip at end if needed
> if self.engine == 'tar.gz':

There are a couple of reasons why this is not ideal:
1) Saving to a network drive uses up to 3x the bandwith of the backups set
(write, read, write-compressed)
2) Saving to a network drive uses up to 2x the original file size to store
during the backup process (original size + compressed size, until finished)
3) Saving to a network drive increases the total backup time because of the
extra r/w.


Version-Release number of selected component (if applicable):
fwbackups-1.43.0-0.1.beta2.fc6

Comment 1 Bernard Johnson 2007-04-26 19:21:51 UTC
Example of wasted time.  Approximately 80 minutes to write archive, then an
additional 115 minutes to compress it after the fact.

INFO :: Apr 26 06:00:02: Starting automatic backup of set 'bjohnson'
INFO :: Apr 26 07:20:07: Compressing the backup archive...
INFO :: Apr 26 09:15:11: Finished automatic backup of set 'bjohnson'

Comment 2 Stewart Adam 2007-04-26 20:46:30 UTC
The way I designed the restore/backup functions I would need to rewrite quite a
bit to get this done and at the moment I don't have very much time, however this
will be my top priority for 1.43.1 which will be soon after 1.43.0 is released.

Comment 3 Stewart Adam 2007-05-13 00:57:16 UTC
Just a little update - this issue was bugging me, so I fixed this in RC1. I
update it in the repos once Fedora 7 comes out of the freeze.

Comment 4 Bernard Johnson 2007-05-22 21:24:33 UTC
Excellent.  I just got back from a trip so I installed rc2 today to give it a spin.

Comment 5 Bernard Johnson 2007-05-23 16:30:20 UTC
Hmm.  When I upgraded, it looks like the crontab file got botched:

$ crontab -l
0 6 * * * fwbackups-run

My backup didn't run this morning because there was no backup set specified.  I
removed that crontab entry and saved the backup set again and it saved the
crontab correctly:

$ crontab -l
0 6 * * * fwbackups-run 'bjohnson'

Comment 6 Stewart Adam 2007-05-23 20:44:05 UTC
That's funny, I had noticed that too but after the first indecent I couldn't
manage to reproduce it...

Comment 7 Stewart Adam 2007-05-25 21:55:34 UTC
*indecent -> incident...

I'm going to close this ticket as it's resolved in the latest build.


Note You need to log in before you can comment on or make changes to this bug.