Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235700 - Upgrade to 2.8.3-2 breaks meeting requests from exchange users
Summary: Upgrade to 2.8.3-2 breaks meeting requests from exchange users
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 8
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-09 18:32 UTC by Erik Iverson
Modified: 2008-03-16 21:43 UTC (History)
2 users (show)

Fixed In Version: evolution-2.12.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-03-16 21:43:41 UTC

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
GNOME Bugzilla 487922 None None None Never

Description Erik Iverson 2007-04-09 18:32:59 UTC
Description of problem:

Evolution, using evolution-connector, stopped correctly handling meeting
requests from Exchange upon upgrade from 2.8.3-1 to 2.8.3-2.  2.8.3-2 is marked
as a security upgrade.  Prior to upgrade, meeting requests work properly.  After
upgrade, meeting requests are shown as "unknown attachment."  The only fix I
found was to remove evolution completely and reinstall, specifying version 2.8.3-1.

Version-Release number of selected component (if applicable): 2.8.3-2

How reproducible:

1) receive a meeting request from another user (your own always work)
2) upgrade to 2.8.3-2
3) view existing, or new, meeting request - now contains only "unknown attachments"

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Comment 1 Frode Tennebø 2007-08-31 09:40:21 UTC
I have the same problem.  I had a FC5 installation (fully updated) which worked 
perfectly, and while upgrading it to FC7 (which involved in waiting for some 
new hardware to arrive) I switched to an FC6 installation (fully updated).  In 
this move I lost propper functioning access to meeting/appointment requests 
("unknown attachment").

I have tried to downgrade to older versions:

[root@modesty tmp]# rpm -qa|grep evolution

But this gives the same behaviour.

F7 also behaves in the same manner with the following versions:

[root@rsh etc]# rpm -qa | grep evolution| sort | uniq

Comment 2 Matthew Barnes 2007-08-31 15:26:26 UTC
Here is the difference between evolution-2.8.3-1.fc6 and evolution-2.8.3-2.fc6.
 It fixes a security flaw when previewing memos.

--- evolution-2.10.0/calendar/gui/e-cal-component-memo-preview.c.CVE-2007-1002 
2007-03-29 16:51:41.000000000 -0400
+++ evolution-2.10.0/calendar/gui/e-cal-component-memo-preview.c       
2007-03-29 16:51:56.000000000 -0400
@@ -185,7 +185,7 @@

-               gtk_html_stream_printf(stream, string->str);
+               gtk_html_stream_printf(stream, "%s", string->str);

                g_string_free (string, TRUE);

This is what broke metting requests?

Comment 3 Frode Tennebø 2007-08-31 17:48:03 UTC
No.  I experienced the same behaviour in both evolution-2.8.3-1.fc6 and 
evolution-2.8.3-2.fc6.  The last time this worked was in FC5 (presumably) with 
the versions:  evolution-2.6.3-2.fc5 and evolution-connector-2.6.3-2.fc5.

Comment 4 Frode Tennebø 2007-09-03 10:06:48 UTC
After som trial and error I ended up with the following set of evolution 
components which works on FC6:

[root@modesty tmp]# rpm -qa | grep evolution

I tried all the different inbetween version of evolution with no luck, so the 
bug is either in evolution-data-server or evolution-connector.

I'll try to update single components when I get some spare time, but there are 
some nasty dependencies there which broke some of the symlinks which I had to 
manually recreate to the correct versions.

Comment 5 Frode Tennebø 2007-09-03 11:25:57 UTC
OK, I bumbed all of the below up to the version as of Dec 04 2006:


and the problem arose again.  So sometimes between Nov 01 2006 and then, the 
bug was introduced.  I then downgraded to evolution- and the 
meetings are again OK, however, now it seems that there are some instabilities 
with authentication with the server and I keep getting locked out.  While I 
wait for a solution I'm reverting to last good as described in my previous post.

Comment 6 Matthew Barnes 2007-10-05 15:50:37 UTC
Is this problem still present on Fedora 8 Test 2 or later?

Comment 7 Frode Tennebø 2007-10-09 11:59:05 UTC
I haven't tried F8T2 - as I'm running in a production environment I really 
don't want to bump the whole system.  Are there packages available for F7?

Interestingly enought I have stared to receive meeting requests which behaves 
exactly like the original problem, i.e. meeting requests are shown as "unknown 
attachment."  So, the workaround above seems to no longer work.

Can it be something marginal in the way Outlook/Exchange constructs these 
messages, which again is based on some set of settings, which can change from 
request to request, which makes Evolution fall over?

Comment 8 Matthew Barnes 2007-10-10 21:11:31 UTC
Thanks for responding.  The Evolution packages in Fedora 7 are for only for
version 2.10, which is no longer seeing regular updates.  I think you may be
able to install the Fedora 8 Evolution packages without bumping the entire
desktop, if you care to try.  You can always tell 'yum' to abort if it wants to
pull into too many additional packages.

Comment 9 Frode Tennebø 2007-10-12 13:31:14 UTC
[ft@modesty /tmp]$ rpm -Uvh evolution-*
warning: evolution-data-server-1.12.0-1.fc8.i386.rpm: Header V3 DSA signature: 
NOKEY, key ID 30c9ecf8
error: Failed dependencies:
        gnome-icon-theme >= 2.19.91 is needed by evolution-2.12.0-8.fc8.i386
        gtk2 >= 2.12.0 is needed by evolution-2.12.0-8.fc8.i386 is needed by evolution-2.12.0-8.fc8.i386 is needed by evolution-2.12.0-8.fc8.i386
        glib2 >= 2.14.0 is needed by evolution-data-server-1.12.0-1.fc8.i386 is needed by evolution-data-server-1.12.0-1.fc8.i386 is needed by evolution-exchange-2.12.0-1.fc8.i386 is needed by (installed) nautilus-sendto-0.7-
5.fc6.i386 is needed by (installed) gnome-panel-2.16.3-
2.fc6.i386 is needed by (installed) ekiga-2.0.5-3.fc6.i386 is needed by (installed) bug-buddy-2.16.0-
4.fc6.i386 is needed by (installed) control-center-2.16.3-
11.fc6.i386 is needed by (installed) pidgin-2.0.2-

Do you guarantee --nodeps? :-)

Comment 10 Frode Tennebø 2007-10-25 14:58:32 UTC
OK.  I have upgraded one machine to the latest F8 release.  But the problem
still persists. These are the versions I use:

[root@modesty ~]# rpm -q fedora-release fedora-release-notes
[root@modesty ~]# rpm -qa | grep evolution

Comment 11 Matthew Barnes 2007-10-25 16:30:16 UTC
The problem persists for new meeting requests or existing meeting requests?

Comment 12 Frode Tennebø 2007-10-29 09:19:33 UTC
OK.  To clarify:

Everything was working fine in FC5, both new and existing meeting requests.  
Then I upgraded to FC6 and I had to downgrade some of the evolution packages to 
get meeting requests working again (see above).  At some point new meeting 
requests started to appear as "unknown attachments" while existing behaved 

Upgrading to F8T3 did not change this for new meeting requests.  I no longer 
have old meeting requests available for testing, sorry.

Comment 13 Frode Tennebø 2007-10-29 11:16:48 UTC
I can now confirm that with current evolution also existing meeting requests
have "unknown attachment".  This is contrary to my experience when it was
working in FC6 and F7 with FC6 evolution rpm-packages, but when it failed after
some time for new meeting requests.  Then existing meeting requests were
displayed as normal.

When I refer to "existing meeting requests" I mean meeting requests in a mail
folder somewhere which has not been accepted (or any other action) - obviously -
due to the "unknown attachment" problem. 

Comment 14 Milan Crha 2007-10-29 14:35:47 UTC
Can you try to set Edit->Preferences->Mail Preferences, tab HTML Messages and in
the section "Plain Text Mode" change to "Show HTML if present". Maybe it will
help. Other option is to disable Prefer plain-text plugin from Edit->Plugins.

I noticed that this plugin generates those "unknown attachment" attachments,
even I'm not sure if it is the case now.

Comment 15 Frode Tennebø 2007-10-29 15:08:46 UTC
I disabled "Prefer plain-text" from Edit->Plugin as suggested, and - Wow! - it
now works again.  I can't remember enabling this option tho.......

Thanks, Milan!

Comment 16 Milan Crha 2007-10-30 09:12:25 UTC
maybe fix from gnome's bug will
help here too.

Comment 17 Matthew Barnes 2008-03-16 21:43:41 UTC
Milan's patch for this issue should be in the latest Fedora 8 update now.

Closing as CURRENTRELEASE, but feel free to reopen if you still encounter the
problem after upgrading.

Note You need to log in before you can comment on or make changes to this bug.